PAT(Advanced Level) A+B Format

  1. A+B Format (20)

時間限制
400 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue
Calculate a + b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

Code:

import java.text.DecimalFormat;
import java.text.NumberFormat;
import java.util.Scanner;

//1001. A+B Format (20)  PAT 
public class Main{

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        long res=sc.nextLong()+sc.nextLong();

        DecimalFormat df = (DecimalFormat)NumberFormat.getInstance();
        df.applyPattern(",###");    
        System.out.println(df.format(res));

    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章