hdu4965——Fast Matrix Calculation(快速矩陣冪優化)

Problem Description
One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her.

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation.

Step 1: Calculate a new N*N matrix C = A*B.
Step 2: Calculate M = C^(N*N).
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’.
Step 4: Calculate the sum of all the elements in M’.

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.

Input
The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B.

The end of input is indicated by N = K = 0.

Output
For each case, output the sum of all the elements in M’ in a line.

Sample Input
4 2
5 5
4 4
5 4
0 0
4 2 5 5
1 3 1 5
6 3
1 2 3
0 3 0
2 3 4
4 3 2
2 5 5
0 5 0
3 4 5 1 1 0
5 3 2 3 3 2
3 1 5 4 5 2
0 0

Sample Output
14
56

看題目的時候至少注意了兩點:
一是矩陣的規模有1000*1000,太大,而另一個數m太小,可疑
二是步驟寫得太詳細,不太可能直接跟着走就能過
然而我還是控制不住自己交了發上去爆棧了。。。。

題目是要求(A*B)^(N*N),其實就是A*B*A*B*A*B*A*B*A*B…,把中間的B*A提出來就成了A*(B*A)^(N*N-1)*B,而B*A是6*6的矩陣,運算時間一下降下來很多

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <algorithm>
#include <queue>
#include <iomanip>
#define INF 0x3f3f3f3f
#define MAXN 10000005
#define Mod 10000007
using namespace std;
const int N = 10;
long long m,n;
struct Matrix
{
    int mat[N][N];
};
Matrix mul(Matrix a,Matrix b)
{
    Matrix res;
    for(int i=0; i<m; ++i)
        for(int j=0; j<m; ++j)
        {
            res.mat[i][j]=0;
            for(int k=0; k<m; ++k)
            {
                res.mat[i][j]+=a.mat[i][k]*b.mat[k][j];
                res.mat[i][j]%=6;
            }
        }
    return res;
}
Matrix pow_matrix(Matrix a,long long k)
{
    Matrix res;
    memset(res.mat,0,sizeof(res.mat));
    for(int i=0; i<m; ++i)
        res.mat[i][i]=1;
    while(k!=0)
    {
        if(k%2)
            res=mul(res,a);
        a=mul(a,a);
        k>>=1;
    }
    return res;

}
int a[1005][1005],b[1005][1005],c1[1005][1005],c2[1005][1005];
int main()
{
    Matrix tmp;
    while(~scanf("%I64d%I64d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        memset(tmp.mat,0,sizeof(tmp.mat));
        for(int i=0; i<n; ++i)
            for(int j=0; j<m; ++j)
                scanf("%d",&a[i][j]);
        for(int i=0; i<m; ++i)
            for(int j=0; j<n; ++j)
                scanf("%d",&b[i][j]);
        for(int i=0; i<m; ++i)
            for(int j=0; j<m; ++j)
            {
                tmp.mat[i][j]=0;
                for(int k=0; k<n; ++k)
                {
                    tmp.mat[i][j]+=b[i][k]*a[k][j];
                    tmp.mat[i][j]%=6;
                }
            }
        Matrix p=pow_matrix(tmp,n*n-1);
        for(int i=0; i<n; ++i)
            for(int j=0; j<m; ++j)
            {
                c1[i][j]=0;
                for(int k=0; k<m; ++k)
                {
                    c1[i][j]+=a[i][k]*p.mat[k][j];
                    c1[i][j]%=6;
                }
            }
        for(int i=0; i<n; ++i)
            for(int j=0; j<n; ++j)
            {
                c2[i][j]=0;
                for(int k=0; k<m; ++k)
                {
                    c2[i][j]+=c1[i][k]*b[k][j];
                    c2[i][j]%=6;
                }
            }
        long long ans=0;
        for(int i=0; i<n; ++i)
            for(int j=0; j<n; ++j)
                ans+=c2[i][j];
        printf("%I64d\n",ans);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章