poj3096——Surprising Strings(STL)

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the “Puzzling Adventures” column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*
Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

給出一段字符串,D-pair表示字符串中相距爲D的兩個字符,比如ABC的0-pair是AB和AC,同理1-pair是AC。
如果這個字符串的每個D-pair都不相同,那這個字符串就是surprising的,
ABAB就不是,因爲0-pair有兩個AB
題目求一個字符串是不是surprising的,用set保存出現過的pair就行了

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <algorithm>
#include <queue>
#include <iomanip>
#include <map>
#include <cctype>
#define INF 0x3f3f3f3f
#define MAXN 1000005
#define Mod 1000000007
using namespace std;
char s[100];
set<string> table;
int main()
{
    while(~scanf("%s",s))
    {
        if(s[0]=='*')
            break;
        int len=strlen(s),flag;
        for(int i=0;i<=len-2;++i)
        {
            table.clear();
            flag=0;
            for(int j=0;j+i+1<len;++j)
            {
                string tmp="";
                tmp+=s[j];
                tmp+=s[j+i+1];
                //cout<<tmp<<" ";
                if(table.find(tmp)==table.end())
                    table.insert(tmp);
                else
                    flag=1;
                if(flag)
                    break;
            }
            //cout<<endl;
            if(flag)
                break;
        }
        if(flag)
            cout<<s<<" is NOT surprising."<<endl;
        else
            cout<<s<<" is surprising."<<endl;
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章