HDU1035 Robot Motion(java)

Problem Description

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input
There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output
For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word “step” is always immediately followed by “(s)” whether or not the number before it is 1.

Sample Input
3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0

Sample Output
10 step(s) to exit
3 step(s) before a loop of 8 step(s)

很簡單的模擬題,值得一提的是java中輸出要使用System.out.println(),不要使用System.out.printf(),使用System.out.printf()在提交到OJ上的時候就會出現presention error,具體原因暫時沒搞清楚!

import java.util.Scanner;


public class P1035 {

    char[][] maze ;
    int[][] vis ;
    int r, c, s;
    public static void main(String[] args) {
        new P1035().run();
    }

    public void run(){
        Scanner scanner = new Scanner(System.in);
        r = scanner.nextInt();
        c = scanner.nextInt();
        while(r != 0 && c != 0){
            s = scanner.nextInt();
            maze = new char[r + 1][c + 1];
            vis = new int[r + 1][c + 1];
            for (int i = 1; i <= r; i++) {
                String temp = scanner.next();
                for (int j = 1; j <= c; j++) {
                    maze[i][j] = temp.charAt(j - 1);
                    vis[i][j] = 0;
                }
            }
            int i, j, step;
            i = 1;
            j = s;
            step = 0;
            while (i > 0 && i <= r && j > 0 && j <= c  && vis[i][j] == 0) {
                vis[i][j] = ++step;
                switch (maze[i][j]) {
                case 'N':
                    i -= 1;
                    break;
                case 'S':
                    i += 1;
                    break;
                case 'W':
                    j -= 1;
                    break;
                case 'E':
                    j += 1;
                    break;
                }
            }
            if(i <= 0 || i > r || j <= 0 || j > c){
                /**
                 * system.out.printf();  presention error
                 */
                System.out.println(step + " step(s) to exit");
            }else{
                System.out.println((vis[i][j] - 1) + " step(s) before a loop of "+ 
                        (step - vis[i][j] + 1) + " step(s)");
            }
            r = scanner.nextInt();
            c = scanner.nextInt();
        }
        scanner.close();
    }

}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章