Big Event in HDU (HDU-1171)(母函數)

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2
10 1
20 1
3
10 1 
20 2
30 1
-1

Sample Output

20 10
40 40

題意:大概就是給你一堆東西,第一行數據表示東西的種類,而後面再輸入兩個數,第一個代表物品的價值(v) ,第二個代表物品的個數(n),然後需要你開始按照價值分配給 a 和 b 兩個組,同時要求 a ,b 兩組後面的價值要儘可能的接近,並且保證 a 組的所獲得價值不小於 b 組所獲得的價值。

思路:這道題的話,難點在於怎麼用母函數來做,在讀題之後,我們發現它讓你將總和/2,然後我們算出總和,套用一下模板即可。

AC代碼:

#include <bits/stdc++.h>
typedef long long ll;
const int maxx=250010;
const int inf=0x3f3f3f3f;
using namespace std;
int sup[maxx],temp[maxx];
int v[maxx],m[maxx];
int main()
{
    int n;
    while(~scanf("%d",&n) && n>=0)
    {
        for(int i=0; i<n; i++)
            scanf("%d%d",&v[i],&m[i]);
        int last=0,last2;
        memset(sup,0,sizeof(sup));
        sup[0]=1;
        for(int i=0; i<n; i++)
        {
            last2=last+v[i]*m[i];
            memset(temp,0,sizeof(int)*(last2+1));
            for(int j=0; j<=m[i] && j*v[i]<=last2; j++)
            {
                for(int k=0; k<=last && k+j*v[i]<=last2; k++)
                {
                    temp[k+j*v[i]]+=sup[k];
                }
            }
            memcpy(sup,temp,sizeof(int)*(last2+1));
            last=last2;
        }
        for(int i=last/2; i>=0; i--)
        {
            if(sup[i]!=0)
            {
                printf("%d %d\n",last-i,i);
                break;
            }
        }
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章