PTA_PAT甲級_1068 Find More Coins (30分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 10^​4​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10^​4 , the total number of coins) and M (≤10^​2 , the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the face values V1≤V​2≤⋯≤Vk​ such that V1​​ +V2​​ +⋯+V​k =M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output “No Solution” instead.

Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution

題意:
給出N枚硬幣的面值,用這些硬幣組成M價值,若有解決方案則輸出字典序最小結果,否則輸出No Solution

分析:
01揹包問題,質量與價值等價,用一個數組存儲;因爲要按字典序輸出,所以先把數組逆序排列,這樣最後更新的是更小的數,否則較小的結果之後會被更新爲最大;用一個數組記錄每個元素是否被選用,用來輸出狀態

代碼:

#include<iostream>
#include<algorithm>
using namespace std;

#define MAXN 10010
#define MAXV 110
int w[MAXN], dp[MAXN]={0};//w[i]爲錢幣面值
bool choice[MAXN][MAXN], flag[MAXN];
bool cmp(int a, int b){//從大到小排序 
	return a>b;
} 

int main()
{
    int N, M;
	cin>>N>>M;
	for(int i=1;i<=N;i++) cin>>w[i];
	sort(w+1, w+N+1, cmp);//逆序排列
	for(int i=1;i<=N;i++){
		for(int v=M;v>=w[i];v--){
			if(dp[v]<=dp[v-w[i]]+w[i]){//等於時也要放 
				dp[v] = dp[v-w[i]] + w[i];
				choice[i][v] = 1;//放入第i件物品 
			}else choice[i][v] = 0;//不放第i件物品 
		}
	} 
	if(dp[M]!=M) cout<<"No Solution";//最大值不爲M即無解
	else{//記錄最優路徑 
		int k=N, num=0, v=M;
		while(k>=0){
			if(choice[k][v]==1){//如果選用了k 
				flag[k] = true;
				v -= w[k];//下一輪考慮v刨去k面值後的情況 
				num++;//用到的硬幣個數加1 
			}else flag[k] = false;
			k--;//待選硬幣數減1 
		}
		for(int i=N;i>=1;i--){//w已逆序 
			if(flag[i]==true){//如果當前面值被選中了 
				cout<<w[i];
				num--;
				if(num>0) cout<<" ";
			}
		} 
	} 
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章