PTA_PAT甲級_1076 Forwards on Weibo (30分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:
For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

題意:
每個用戶能看到自己關注的用戶發的微博,分別給出N個用戶關注的對象,和K個需查詢的用戶,分別輸出這些用戶發一條微博在L層內最多可能有多少次轉發(假設看到就會轉發並每個人只轉發一次)

分析:
與層有關的遍歷用BFS更適合

代碼:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector> 
#include<queue>
using namespace std;

#define MAXV 1020
struct Node{
	int id;//節點編號 
	int layer;//節點層號 
};
vector<Node> Adj[MAXV];//鄰接表
bool inq[MAXV] = {false};//頂點是否已被加入過隊列 

int BFS(int s, int L){//start爲起始節點,L爲層數上限 
	int numForward = 0;//轉發數 
	queue<Node> q;//BFS隊列 
	Node start;//定義起始節點
	start.id = s;//起始節點編號
	start.layer = 0;//起始節點層號爲0
	q.push(start);//將起始節點壓如隊列
	inq[start.id] = true;//起始節點編號設爲已加入隊列
	while(!q.empty()){
		Node topNode = q.front();//取出隊首節點
		q.pop();//隊首節點出隊
		int u = topNode.id;//隊首節點的編號
		for(int i=0;i<Adj[u].size();i++){
			Node next = Adj[u][i];//從u出發能到達的節點next
			next.layer = topNode.layer + 1;//next的層號等於當前節點層號加1
			//如果next的編號未被加入過隊列,且next的層次不超過上限L
			if(inq[next.id]==false && next.layer<=L){
				q.push(next);
				inq[next.id] = true;//next的編號設爲已加入過隊列
				numForward++;//轉發數加1 
			} 
		} 
	} 
	return numForward; 
} 

int main()
{
    Node user;
    int N, L, numFollow, idFollow;
    cin>>N>>L;
    for(int i=1;i<=N;i++){
    	user.id = i;
    	cin>>numFollow;
    	for(int j=0;j<numFollow;j++){
    		cin>>idFollow;
    		Adj[idFollow].push_back(user);//邊idFollow->i 
		}
	}
	int numQuery, s;
	cin>>numQuery;//查詢個數 
	for(int i=0;i<numQuery;i++){
		memset(inq, false, sizeof(inq));//inq數組初始化
		cin>>s;
		int numForward = BFS(s, L);
		cout<<numForward<<endl; 
	} 
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章