PTA_PAT甲級_1080 Graduate Admission (30分)

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade GE​​ , and the interview grade G​I. The final grade of an applicant is (G​E +GI)/2. The admission rules are:

The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G​E. If still tied, their ranks must be the same.

Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one’s turn to be admitted; and if the quota of one’s most preferred shcool is not exceeded, then one will be admitted to this school, or one’s other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:
Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant’s GE​​ and G​I, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

Output Specification:
For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:

0 10
3
5 6 7
2 8

1 4

題意:
給出若干學生的初試和麪試成績,按二者之和排名,若總分一樣則按初試排名,初試也一樣則並列,按名次錄取,每個學校有一定錄取名額,每個學生有若干志願,依次檢查其志願學校,若沒錄滿則錄取,若其所有志願學校都錄滿則該生落榜,若幾名考生名次並列,則即使已錄滿也要同時錄取這幾名考生,輸出每個學校的錄取結果

分析:
用兩個結構體分別存儲每個考生和學校的信息,排序,注意並列的情況

代碼:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

struct Student{
	int GE, GI, sum;
	int r, stuID;
	int cho[6];
}stu[40010];

struct School{
	int quato;//招生人數總額度
	int stuNum;//當前實際招生人數
	int id[40010];//招收的學生編號
	int lastAdmit;//記錄最後一個招收的學生編號 
}sch[110];

bool cmpStu(Student a, Student b){
	if(a.sum!=b.sum) return a.sum>b.sum;//按總分從高到低排序 
	else return a.GE>b.GE;//總分相同按GE排序 
}

bool cmpID(int a,int b){
	return stu[a].stuID<stu[b].stuID;//考生編號按從小到大排序 
} 

int main()
{
    int N, M, K;
	cin>>N>>M>>K;
	for(int i=0;i<M;i++){//初始化每個學校 
		cin>>sch[i].quato;//招生人數額度 
		sch[i].stuNum = 0;//當前招生人數
		sch[i].lastAdmit = -1;//最後一個招生學生編號,-1表示不存在 
	} 
	for(int i=0;i<N;i++){//初始化每個學生 
		stu[i].stuID = i;
		cin>>stu[i].GE>>stu[i].GI;
		stu[i].sum = stu[i].GE + stu[i].GI;
		for(int j=0;j<K;j++) cin>>stu[i].cho[j];//K個可申請學校編號 
	} 
	sort(stu, stu+N, cmpStu);//給N爲考生排序
	for(int i=0;i<N;i++){//計算考生排名 
		if(i>0&&stu[i].sum==stu[i-1].sum&&stu[i].GE==stu[i-1].GE) stu[i].r = stu[i-1].r;
		else stu[i].r = i;
	} 
	for(int i=0;i<N;i++){//對每位考生判斷其被哪所學校錄取 
		for(int j=0;j<K;j++){//枚舉考生選擇的每個學校 
			int choice = stu[i].cho[j];
			int num = sch[choice].stuNum;//當前學校的當前招生人數
			int last = sch[choice].lastAdmit;//最後一位錄取考生編號
			if(num<sch[choice].quato||(last!=-1&&stu[i].r==stu[last].r)){//未招滿或並列 
				sch[choice].id[num] = i;//錄取該考生
				sch[choice].lastAdmit = i;
				sch[choice].stuNum++;
				break; 
			} 
		} 
	} 
	for(int i=0;i<M;i++){//對M所學校 
		if(sch[i].stuNum>0){//如果有找到學生 
			sort(sch[i].id, sch[i].id+sch[i].stuNum, cmpID);//按ID排序
			for(int j=0;j<sch[i].stuNum;j++){
				cout<<stu[sch[i].id[j]].stuID;
				if(j<sch[i].stuNum-1) cout<<" ";
			} 
		}
		cout<<endl;
	}
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章