poj - 3071 Football

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all ij, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins)  = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
= p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

思路:

概率dp。

dp[i][j]表示第i場比賽第j個隊勝利的概率。

dp[i][j] = sigma(dp[i-1][j]*dp[i-1][k]*p[j][k])。k爲j的相鄰隊伍。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int MAXN = 150;
double a[MAXN][MAXN];
double dp[MAXN][MAXN];
 
int main()
{
    int n, m, i, j, k, ans;
    while (~scanf("%d",&n) && n != -1)
    {
        m = 1 << n;
        for (i = 0; i < m; i++)
		{
            for (j = 0; j < m; j++)
			{
                scanf("%lf", &a[i][j]);
			}
		}
        memset(dp, 0, sizeof(dp));
        for (i = 0; i < m; i++)
		{
            dp[0][i] = 1;
		}
        for (i = 1; i <= n; i++)
		{
            for (j = 0; j < m; j++)
			{
                for (k = 0; k < m; k++)
                {
                    int p = k >> (i-1);
					int q = j >> (i-1);
                    if (p % 2)
                    {
                        p--;
                        if (p == q)
						{
                            dp[i][j] += dp[i-1][j] * dp[i-1][k]*a[j][k];
						}
                    }
                    else
                    {
                        p++;
                        if (p == q)
						{
                            dp[i][j] += dp[i-1][j] * dp[i-1][k]*a[j][k];
						}
                    }
                }
			}
		}
        ans = 0;
        for (i = 0; i < m; i++)
        {
            if (dp[n][ans] < dp[n][i])
			{
                ans = i;
			}
        }
        printf("%d\n",ans+1);
    }
 
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章