HDU 1022 火車進出站問題

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9733    Accepted Submission(s): 3539

Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.


Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
3 123 321 3 123 312
 

Sample Output
Yes. in in in out out out FINISH No. FINISH
題目大概意思:有N輛火車,以序列1方式進站,判斷是否能以序列2方式出棧。進站不一定是一次性進入,也就是說中途可以出站。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#include<stack>
#define maxlen 1000000
using namespace std;
int res[maxlen+5];
int main()
{
	char s1[100],s2[100];
	int n;
	while(cin>>n>>s1>>s2)
    {
        int i=1,j=0,k=1;
        stack<char> s;
        s.push(s1[0]);
        res[0]=1;
        while(i<n||j<n)
        {
            if(!s.empty()&&s.top()==s2[j])
            {
                res[k]=-1;
                s.pop();
                j++;
                k++;
            }
            else
            {
                s.push(s1[i]);
                res[k]=1;
                k++;
                i++;
            }
        }
        if(k==(n*2))
            cout<<"Yes."<<endl;
        else
        {
            cout<<"No."<<endl<<"FINISH"<<endl;
            continue;
        }
        for(i=0;i<n*2;i++)
        {
            if(res[i]==1)
                cout<<"in"<<endl;
            else if(res[i]==-1) cout<<"out"<<endl;
        }
        cout<<"FINISH"<<endl;
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章