Function Run Fun--CSU-ACM2017暑期訓練3-遞推與遞歸



We all love recursion! Don't we? 


Consider a three-parameter recursive function w(a, b, c): 


if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 



if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 
w(20, 20, 20) 


if a < b and b < c, then w(a, b, c) returns: 
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 


otherwise it returns: 
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 


This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 
Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output
Print the value for w(a,b,c) for each triple.
Sample Input
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1
Sample Output
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1










當a,b,c過大時,我們就會發現其實這個過程中某些情況被遞歸了很多次,浪費了不少的時間。但是隻要我們中途當第一次遞歸到這種情況時能把這個值存儲下來,之後的遞歸再遇到這種情況時就直接用這個值,無需再把這種情況遞歸下去。這樣我們就能節省許多時間。這就是記憶化搜索的基本思想吧。



#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int store[24][24][24];

int recur(int a,int b,int c)
{
    if(a<=0||b<=0||c<=0)return 1;
    if(a>20||b>20||c>20)return recur(20,20,20);
    if(store[a][b][c])return store[a][b][c];
    if(a<b&&b<c) store[a][b][c]=recur(a,b,c-1)+recur(a,b-1,c-1)-recur(a,b-1,c);
    else store[a][b][c]=recur(a-1,b,c)+recur(a-1,b-1,c)+recur(a-1,b,c-1)-recur(a-1,b-1,c-1);
    return store[a][b][c];
}

int main()
{
    int a,b,c;
    memset(store,0,sizeof(store));
    while(cin>>a>>b>>c)
    {
        if(a==-1&&b==-1&&c==-1)break;
        printf("w(%d, %d, %d) = %d\n",a,b,c,recur(a,b,c));
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章