POJ1751-Highways(最小生成樹+並查集)

Highways
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17777 Accepted: 5213 Special Judge
Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can’t reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.
Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.
Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.
Sample Input

9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2
Sample Output

1 6
3 7
4 9
5 7
8 3
題目:PO1751
題意:建造公路,給定n個城市的座標,以及一些存在的高速公路。現在問如果需要聯通所有城市,建造最短的總公路長度,輸出所建公路的端點。
思路:跑一顆最小生成樹,輸出新建邊的斷點即可。
AC代碼:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<queue>
#define met(s,k) memset(s,k,sizeof s)
#define scan(a) scanf("%d",&a)
#define scanl(a) scanf("%lld",&a)
#define scann(a,b) scanf("%d%d",&a,&b)
#define scannl(a,b) scanf("%lld%lld",&a,&b)
#define scannn(a,b,c) scanf("%d%d%d",&a,&b,&c)
#define prin(a) printf("%d\n",a)
#define prinl(a) printf("%lld\n",a)
using namespace std;
typedef long long ll;
const int maxn=755;
const double eps=1e-4;
int n,m,father[maxn],num,ranks[maxn];
struct node
{
    int x,y;
}c[maxn+100];
struct edge
{
    int st,en;
    double len;
    friend bool operator< (const edge &a,const edge &b)
    {
        return a.len<b.len;
    }
}e[maxn*maxn];
void init()
{
    for(int i=1;i<=n;i++)father[i]=i;
}
void add(int x,int y)
{
    e[num].st=x;
    e[num].en=y;
    e[num++].len=sqrt((double)(abs(c[x].x-c[y].x)*abs(c[x].x-c[y].x)+abs(c[x].y-c[y].y)*abs(c[x].y-c[y].y)));
}
int findfather(int x)
{
    return father[x]==x?x:father[x]=findfather(father[x]);
}
void unite(int x,int y)
{
    x=findfather(x);
    y=findfather(y);
    if(ranks[x]<ranks[y])
    {
        father[x]=y;
    }
    else
    {
        father[y]=x;
        if(ranks[x]==ranks[y])ranks[x]++;
    }
}
void kruskar()
{
    for(int i=0;i<num;i++)
    {
        if(findfather(e[i].st)!=findfather(e[i].en))
        {
            unite(e[i].st,e[i].en);
            printf("%d %d\n",e[i].st,e[i].en);
        }
    }
}
int main()
{
    scan(n);
    init();
    for(int i=1;i<=n;i++)scann(c[i].x,c[i].y);
    scan(m);
    for(int i=0;i<m;i++)
    {
        int x,y;
        scann(x,y);
        unite(x,y);
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=i+1;j<=n;j++)
        {
            add(i,j);
        }
    }
    sort(e,e+num);
    kruskar();
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章