poj1094 Sorting It All Out 拓撲排序

Sorting It All Out
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 33337   Accepted: 11614

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

拓撲排序算法思想:

(1) 從有向圖中選取一個沒有前驅(即入度爲0)的頂點,並保存到隊列裏;

(2) 從有向圖中刪去此頂點以及所有以它爲尾的弧;

(3) 重複上述兩步,直至圖空,或者圖不空但找不到無前驅的頂點爲止,最後輸出隊列。


#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#include <queue>
#include <algorithm>
#include <map>
#include <stack>
using namespace std;

const int MAXN = 26;
const int INF = 0x3f3f3f3f;
int n, m;
int inDegree[MAXN];
bool G[MAXN][MAXN];
char que[MAXN + 1];

int TopoSort() {
    memset(que, 0, sizeof(que));
    int ind[MAXN];
    memcpy(ind, inDegree, sizeof inDegree);
    int flag = 1, cnt = 0;

    for (int i = 0; i < n; ++i) {
        int zero = 0, pos;
        for (int j = 0; j < n; ++j) {
            if (ind[j] == 0) {
                ++zero;
                pos = j;
            }
        }
        if (zero == 0) {
            return 0;
        }
        if (zero > 1) {
            flag = -1;
        }
        que[cnt++] = pos + 'A';
        ind[pos] = -1;
        for (int j = 0; j < n; ++j) {
            if (G[pos][j]) {
                --ind[j];
            }
        }
    }
    return flag;
}

int main() {
#ifdef NIGHT_13
    freopen("in.txt", "r", stdin);
#endif
    while (scanf("%d%d%*c", &n, &m), n + m) {
        memset(inDegree, 0, sizeof inDegree);
        memset(G, 0, sizeof G);

        int sign = -1;
        for (int i = 1; i <= m; ++i) {
            char x, y;
            scanf("%c%*c%c%*c", &x, &y);
            if (sign != -1) continue;

            x -= 'A', y -= 'A';
            G[x][y] = true;
            inDegree[y]++;

            sign = TopoSort();
            if (sign == 1) {
                printf("Sorted sequence determined after %d relations: %s.\n", i, que);
            } else if (sign == 0) {
                printf("Inconsistency found after %d relations.\n", i);
            }
        }
        if (sign == -1) {
            printf("Sorted sequence cannot be determined.\n");
        }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章