hdu 1520 (樹形dp)

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output
Output should contain the maximal sum of guests’ ratings.

Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output
5

上司和直系下屬不能同時出現,求能獲得的最大價值

#ifdef WSM
#include <bits:stdc++.h>
#else
#include <bits/stdc++.h>
#endif
#define mem(a) memset(a,0,sizeof(a));
using namespace std;
typedef long long ll;
const int N=6e3+7;
int f[N][2],in[N];
vector<int> q[N];
void dfs(int x)
{
    for(int i=0;i<q[x].size();i++)
    {
        int d=q[x][i];
        dfs(d);
        f[x][1]+=f[d][0];//如果x來的話,那麼一定是從他的直系下屬不來的情況轉移
        f[x][0]+=max(f[d][1],f[d][0]);//如果x不來,那麼就是他的直系下屬來或者不來的最大值轉移(針對每個下屬來或不來單獨考慮,所以+=)
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<=n;i++)
            q[i].clear();
        mem(f);
        mem(in);
        for(int i=1;i<=n;i++)
            scanf("%d",&f[i][1]);//邊緣初始化(每個節點的權值)
        int l,k;
        while(scanf("%d%d",&l,&k)&&l&&k)
        {
            q[k].push_back(l);//記錄k的所以子節點
            in[l]++;//記錄是否爲根節點
        }
        for(int i=1;i<=n;i++)
        {
            if(!in[i])//in[i]爲0,則i必爲根節點
            {
                dfs(i);
                printf("%d\n",max(f[i][0],f[i][1]));//輸出最大的價值
                break;
            }
        }
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章