Bone Collector (簡單的0-1揹包問題) HDU

Bone Collector

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 7   Accepted Submission(s) : 3
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?


Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1

Sample Output
14

 

問題 描述:  給出樣品的個數  和揹包的大小

 給出每個樣品的大小和價值  求 揹包最大的價值

 

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
int dp[1001];
int main()
{
    int test;
    while(scanf("%d",&test)!=EOF)
    {
        while(test--)
        {
            int v[1001];
            int w[1001];
            memset(dp,0,sizeof(dp));
            int n,weight;
            scanf("%d%d",&n,&weight);
            for(int i=1; i<=n; i++)
                scanf("%d",&v[i]);
            for(int i=1; i<=n; i++)
                scanf("%d",&w[i]);
            dp[0]=1;
            for(int i=1; i<=n; i++)
            {
                for(int j=weight; j>=w[i]; j--)
                {
                    if(dp[j]<dp[j-w[i]]+v[i])
                        dp[j]=dp[j-w[i]]+v[i];
                }
            }
            int max=0;
            for(int i=0; i<=weight; i++)
                if(dp[i]>max) max=dp[i];
                printf("%d\n",max-1);
        }
    }
    return 0;
}
/*
1
5 10
1 2 3 4 5
5 4 3 2 1
*/


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章