深度優先搜索 例: Red and Black

題目:

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 


Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 

'#' - a red tile 

'@' - a man on a black tile(appears exactly once in a data set) 

The end of the input is indicated by a line consisting of two zeros. 


Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).


Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

 AC CODE

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 25;

int m,n,ans;
char s[maxn][maxn];
int v[maxn][maxn];
int dx[]={1,-1,0,0}, dy[]={0,0,1,-1};
int dfs(int x,int y)
{
    if(x<0 || y<0 ||x>=n ||y>=m || s[x][y] == '#' || v[x][y]!=0 ) return 0;
    v[x][y] = 1;
    ans++;
    for(int i=0; i<4; i++)
        dfs(x+dx[i], y+dy[i]);
    return ans;

}
int main()
{
    while(~scanf("%d%d",&m,&n)&&(m+n))
    {
        ans=0;
        memset(v,0,sizeof(v));
        for(int i=0; i<n; i++)
            cin>>s[i];

        for(int i=0;i<n;i++)
          for(int j=0; j<m; j++)
             if(s[i][j]=='@'&&v[i][j]==0) dfs(i,j);
        cout<<ans<<endl;
    }

    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章