Bone Collector(0-1揹包模板)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 51860    Accepted Submission(s): 21837


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
 

0-1揹包是最基礎的揹包問題,特點是:每種物品僅有一件,可以選擇放或不放。
用子問題定義狀態:即f[i][v]表示前i件物品恰放入一個容量爲v的揹包可以獲得的最大價值。則其狀態轉移方程便是:
f[i][v]=max{f[i-1][v],f[i-1][v-c[i]]+w[i]}

這個方程非常重要,基本上所有跟揹包相關的問題的方程都是由它衍生出來的。所以有必要將它詳細解釋一下:
“將前i件物品放入容量爲v的揹包中”這個子問題,若只考慮第i件物品的策略(放或不放),那麼就可以轉化爲一個只牽扯前i-1件物品的問題。
在前i件物品放進容量v的揹包時,它有兩種情況:
f[i-1][v]:如果不放第i件物品,那麼問題就轉化爲“前i-1件物品放入容量爲v的揹包中”,價值爲f[i-1][v];
f[i-1][v-c[i]]+w[i]:如果放第i件物品,那麼問題就轉化爲“前i-1件物品放入剩下的容量爲v-c[i]的揹包中”,此時能獲得的最大價值就是f[i-1][v-c[i]]再加上通過放入第i件物品獲得的價值w[i]。
最後比較第一種與第二種所得價值的大小,哪種相對大,f[i][v]的值就是哪種(這裏是重點,理解!)。

 
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int w[1010]={0};
int c[1010]={0};
int val[1010];
int main()
{
	int t,i,j;
	int N,V;
	scanf("%d",&t);
	while(t--)
	{
		memset(val,0,sizeof(val));
		scanf("%d%d",&N,&V);
		for(i=1;i<=N;i++){
			scanf("%d",&w[i]);
		}
		for(i=1;i<=N;i++){
			scanf("%d",&c[i]);
		}
		for(i=1;i<=N;i++)
		{
			for(j=V;j>=c[i];j--)
			{
				val[j]=max(val[j],val[j-c[i]]+w[i]);//這裏可能 剛學的時候不理解,自己模擬一下就懂了; 
			}
		}
		printf("%d\n",val[V]);
	}
	return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章