PAT甲級真題 1076 Forwards on Weibo (30分) C++實現(圖的廣度優先遍歷,BFS)

題目

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
Sample Output:
4
5

思路

添加從用戶指向其粉絲的連線,問題可以轉換爲有向圖的廣度優先遍歷,並加入了層數限制。

用數組v保存當前層次待訪問的節點,用額外的數組newV保存下層待訪問節點,用數組visited記錄節點是否已訪問過。

每層搜索都遍歷v中的節點,將與v相連且未訪問的節點加入newV。當前層訪問結束後,將newV賦值給v,清空newV,繼續下層搜索。


注意不能用dfs,考慮下面的情況:
dfs無法完全搜索
距離限制爲2時,從節點1進行dfs訪問結果爲:1->2->3
而正確結果應該是:1->2->3->4

代碼

#include <iostream>
#include <vector>
using namespace std;

int n, l;
vector<vector<int> > Fans;  //鄰接表存儲粉絲信息

int bfs(int root){
    vector<int> v;
    v.push_back(root);
    vector<int> visited(n+1);
    visited[root] = true;
    int sum = 0;
    vector<int> newV;
    for (int len=0; len<l; len++){
        newV.clear();
        for (int i=0; i<v.size(); i++){
            for (int j=0; j<Fans[v[i]].size(); j++){
                if (!visited[Fans[v[i]][j]]) {
                    visited[Fans[v[i]][j]] = true;
                    newV.push_back(Fans[v[i]][j]);
                    sum++;
                }
            }
        }
        v = newV;
    }
    return sum;
}
int main(){
    cin >> n >> l;
    Fans.resize(n+1);
    for (int i=1; i<=n; i++){
        int m;
        cin >> m;
        for (int j=0; j<m; j++){
            int user;  //i關注的人
            cin >> user;
            Fans[user].push_back(i);
        }
    }
    int k;
    cin >> k;
    while (k--){
        int user;
        cin >> user;
        cout << bfs(user) << endl;
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章