ZOJ-1060 Sort It All Out(拓撲排序 判斷全序成環)

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character “<” and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy…y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy…y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.






題解

  • 每讀到一行關係便進行一次拓撲排序
  • 在排序過程中,判斷中途是否都爲全序,並記錄排序出的節點數。最後若節點數小於總節點數則表示成環(拓撲排序性質)。若爲全序則表示排序完成,不然則繼續讀入關係判斷。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>

#define maxn 50
using namespace std;

int n, m;
int pre[maxn], p, vis[maxn], tmp[maxn];
char ans[maxn];
int mapp[maxn][maxn];

int top_sort()
{
    memset(vis, 0, sizeof vis);
    memcpy(tmp, pre, sizeof pre);
    int len = 0;
    p = 0;
    queue<int> q;
    for(int i=0;i<n;i++)
    {
        if(tmp[i]==0){
            q.push(i);
        }
    }
    int mult = 0;
    while(!q.empty())
    {
        if(q.size()>1) mult = 1;
        int u = q.front();
        ans[p++] = u+'A';
        len++; vis[u] = 1;
        q.pop();
        for(int i=0;i<n;i++)
        {
            if(mapp[u][i] && tmp[i]){
                tmp[i]--;
                if(!tmp[i] && !vis[i]){
                    q.push(i);
                }
            }
        }
    }
    if(len<n) return 0; // 拓撲排序判斷城環的條件
    if(mult) return 2;
    else return 1;
}

int main()
{
    while(scanf("%d %d", &n, &m) && n)
    {
        getchar();
        memset(mapp, 0, sizeof(mapp));
        memset(pre, 0, sizeof pre);
        char S[5];
        int flagg = 0, flags = 0;
        
        for(int i=0;i<m;i++)
        {
            cin>>S;
            int aa = S[0] - 'A', bb = S[2] - 'A';
            pre[bb]++;
            mapp[aa][bb] = 1;
            if(!flagg && !flags){
                int s = top_sort();
                if(s == 0) flagg = i+1;
                else if(s == 1) flags = i+1;
            }
        }
        if(flagg)
        {
            printf("Inconsistency found after %d relations.\n", flagg);
            continue;
        }
        if(flags)
        {
            ans[p++] = 0;
            printf("Sorted sequence determined after %d relations: %s.\n", flags, ans);
            continue;
        }
        puts("Sorted sequence cannot be determined.");
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章