2265 Card Game (Second Edition)


Problem 2265 Card Game (Second Edition)

Accept: 113    Submit: 309
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Fat brother and Maze are playing a kind of special (hentai) game with some cards. In this game, every player gets N cards at first and these are their own card deck. The game goes for N rounds and in each round, Fat Brother and Maze would draw one card from their own remaining card deck randomly and compare for the integer which is written on the cards. The player with the higher number wins this round and score 1 victory point. And then these two cards are removed from the game such that they would not appear in the later rounds. As we all know, Fat Brother is very clever, so he would like to know the expect number of the victory points he could get if he knows all the integers written in these cards.

Note that the integers written on these N*2 cards are pair wise distinct. At the beginning of this game, each player has 0 victory point.

Input

The first line of the data is an integer T (1 <= T <= 100), which is the number of the text cases.

Then T cases follow, each case contains an integer N (1 <=N<=10000) which described before. Then follow two lines with N integers each. The first N integers indicate Fat Brother’s cards and the second N integers indicate Maze’s cards.

All the integers are positive and no more than 10000000.

Output

For each case, output the case number first, and then output the expect number of victory points Fat Brother would gets in this game. The answer should be rounded to 2 digits after the decimal point.

Sample Input

211221 32 4

Sample Output

Case 1: 0.00Case 2: 0.50

Source

第七屆福建省大學生程序設計競賽-重現賽(感謝承辦方閩江學院)


 【題解】:其實我也不太懂,新增了一個知識,也不算新的,upper_bound()裏面是二分的算法的,纔不會超時,就是找比目標函數大的第一個數的下標

【代碼】:
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<vector>
#include<map>
#define MAX 11000
using namespace std;
bool cmp(int a,int b){
    return a>b;
}
long long a1[MAX];
long long a2[MAX];
int main()
{
    int re,cn=1,n;
    scanf("%d",&re);
    while(re--)
    {
        memset(a1,0,sizeof(a1));
        memset(a2,0,sizeof(a2));
        scanf("%d",&n);
        for(int t=0;t<n;t++)
            scanf("%lld",&a1[t]);
        for(int t=0;t<n;t++)
            scanf("%lld",&a2[t]);
        sort(a2,a2+n);
        double cnt=0.0;
        int a;
        for(int t=0;t<n;t++){
            a=upper_bound(a2,a2+n,a1[t])-a2;
            printf("A: %d\n",a);
            cnt+=a;
        }
        printf("Case %d: %.2f\n",cn++,cnt/n);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章