Power Strings【KMP循環節】

Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
解題思路:
典型的kmp求循環節題目。判斷n%(n-f[n])是否等於0,如果等於零說明這個字符串是由多個相同字符串組成的,n/(n-f[n])就是所求答案。
代碼

#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;
const int N = 1000005;
char s[N];
int f[N];
int len;
void getfail(){
    f[0]=0,f[1]=0;
    int j;
    for(int i=1;i<len;i++){
        j=f[i];
        while(j&&s[i]!=s[j]) j=f[j];
        f[i+1]= s[i]==s[j]?j+1:0;
    }
}
int main(){
    while(~scanf("%s",s),s[0]!='.'){
        len=strlen(s);
        getfail();
        if(len%(len-f[len])==0)
            printf("%d\n",len/(len-f[len]));
        else
            printf("1\n");

    }

    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章