Double Queue POJ - 3481

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

0 The system needs to stop serving
KP Add client K to the waiting list with priority P
2 Serve the client with the highest priority and drop him or her from the waiting list
3 Serve the client with the lowest priority and drop him or her from the waiting list

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input
2
1 20 14
1 30 3
2
1 10 99
3
2
2
0
Sample Output
0
20
30
10
0

treap模板題 。。但是感覺自己寫的不是很好
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=200005;


struct node
{
    int l,r,val,w,size,mark;
    int rnd;
}tree[maxn];
int size,root;


void update(int k)
{
    tree[k].size=tree[tree[k].l].size+tree[tree[k].r]
    .size+tree[k].w;
}
void lturn(int &k)
{
    int tmp=tree[k].r;
    tree[k].r=tree[tmp].l;
    tree[tmp].l=k;
    tree[tmp].size=tree[k].size;
    update(k);
    k=tmp;
}
void rturn(int &k)
{
    int tmp=tree[k].l;
    tree[k].l=tree[tmp].r;
    tree[tmp].r=k;
    tree[tmp].size=tree[k].size;
    update(k);
    k=tmp;
}
void insert(int &k,int x,int mm)
{
    //cout<<"insert "<<k<<endl;
    if(k==0)
    {
        size++;  //記錄已經使用的結構體數目
        k=size;
        tree[k].val=x;
        tree[k].mark=mm;
        tree[k].size=1;
        tree[k].w=1;
        tree[k].rnd=rand();
        return ;
    }
    tree[k].size++;
    if(tree[k].val==x)tree[k].w++;
    else if(x>tree[k].val)
    {
        insert(tree[k].r,x,mm);
        if(tree[tree[k].r].rnd<tree[k].rnd)    //右子樹優先級小於根子樹
            lturn(k);
    }
    else
    {
        insert(tree[k].l,x,mm);
        if(tree[tree[k].l].rnd<tree[k].rnd)
            rturn(k);
    }
}
void del(int &k,int x)
{
    if(k==0)return ;
    //cout<<"del"<<endl;
    if(tree[k].val==x)
    {
        if(tree[k].w>1)
        {
            tree[k].w--;
            tree[k].size--;
            return ;
        }

    if(tree[k].l*tree[k].r==0)k=tree[k].l+tree[k].r;   //如果沒有左右子樹或只有一個
    else if(tree[tree[k].l].rnd<tree[tree[k].r].rnd)
        rturn(k),del(k,x);
    else lturn(k),del(k,x);
    }
    else if(tree[k].val<x)tree[k].size--,del(tree[k].r,x);
    else tree[k].size--,del(tree[k].l,x);
}

int query_num1(int k,int x)
{
    if(k==0)return 0;
    //cout<<"rank "<<k<<endl;
    if(x<=tree[tree[k].r].size)
      {
        return query_num1(tree[k].r,x);
      }
    else if(x>tree[tree[k].r].size+tree[k].w)
       {

        return query_num1(tree[k].l,x-tree[tree[k].r].size
        -tree[k].w);
       }
    else
    {
        return k;
    }
}
int query_num2(int k,int x)
{
    if(k==0)return 0;
    if(x<=tree[tree[k].l].size)
        return query_num2(tree[k].l,x);
    else if(x>tree[tree[k].l].size+tree[k].w)
        return query_num2(tree[k].r,x-tree[tree[k].l].size-tree[k].w);
    else return k;
}

int main()
{
    int op;
    root=0,size=0;
    while(scanf("%d",&op)!=-1)
    {

        if(op==0)break;
        if(op==2)
           printf("%d\n",tree[query_num1(root,1)].mark),del(root,tree[query_num1(root,1)].val);
        if(op==1)
           {
               int a,b;
               scanf("%d%d",&a,&b);
               insert(root,b,a);
           }
         if(op==3)
            printf("%d\n",tree[query_num2(root,1)].mark),del(root,tree[query_num2(root,1)].val);

    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章