POJ - 2184(78/600)

“Fat and docile, big and dumb, they look so stupid, they aren’t much
fun…”
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si’s and, likewise, the total funness TF of the group is the sum of the Fi’s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.
Input
* Line 1: A single integer N, the number of cows

  • Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.
    Output
  • Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input
5
-5 7
8 -6
6 -3
2 1
-8 -5
Sample Output
8
Hint
OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

這個題就告訴我們在數據量這麼小的時候除了區間dp爆搜還可以揹包….
完全忘了這麼個東西了

然後還有一個事情就是不管什麼樣的dp永遠都是隻維護一個屬性的…
雙屬性是不可能dp出來的….

還有一個事情就是dp數組村的不一定是最優解還可能是一個可能取得解….

//#include<bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int st[101],ft[101],n,dp[2][260001];
int ling=130000;
int main()
{
    scanf("%d",&n);
    for(int a=1;a<=n;a++)scanf("%d%d",&st[a],&ft[a]);
    memset(dp,-0x3f,sizeof(dp));
    dp[0][ling]=0;
    for(int a=1;a<=n;a++)
    {
        for(int b=0;b<=ling+100000;b++)dp[a%2][b]=dp[(a+1)%2][b];
        for(int b=0;b<=ling+100000;b++)
        {
            if(b-st[a]<0)continue;
            dp[a%2][b]=max(dp[a%2][b],dp[(a+1)%2][b-st[a]]+ft[a]);
        }
    }
    int dan=0;
    for(int a=ling;a<=ling+100000;a++)
    {
        if(dp[n%2][a]<0)continue;
        dan=max(dp[n%2][a]+a-ling,dan);
    }
    cout<<dan;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章