acm pku 1056 IMMEDIATE DECODABILITY的代碼實現

 

IMMEDIATE DECODABILITY

Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable
 

Source

Pacific Northwest 1998

 

       這道題目事實上,就是求編碼的有效性,或者說是該編碼是否可以進行譯碼。其算法思想如下:判斷某編碼羣中,任意一個編碼是否是其它任意編碼的前綴,這個問題是容易的。舉個例子,判斷Code[i]是否是Code[j]的前綴,用函數strstr(Code[i], Code[j]) ?= &Code[i][0]實現。

 

具體實現如下:

#include "iostream"

using namespace std;

 

char Code[10][10];

int SetNum = 0;

 

void Judge(int CodeNum)

{

       bool bjudge = true;

       int i, j;

 

       SetNum ++;

       for(i = 0; i < CodeNum; i ++)

       {

              for(j = i+1; j < CodeNum; j ++)

              {

                     if(strstr(Code[i], Code[j]) == &Code[i][0] || strstr(Code[j], Code[i]) == &Code[j][0])

                     {

                            bjudge = false;

                            break;

                     }

              }

       }

 

       if(bjudge)

       {

              cout << "Set " << SetNum << " is immediately decodable" <<endl;

       }

       else

       {

              cout << "Set " << SetNum << " is not immediately decodable" <<endl;

       }

}

 

int main(void)

{

       int i, CodeNum;

      

       while(cin>>Code[0])

       {

              i = 0;

              CodeNum = 0;

              while(strcmp(Code[i], "9") != 0)

              {

                     CodeNum ++;

                     i ++;

                     cin >> Code[i];

              }

              Judge(CodeNum);

       }

 

       return 0;

}

 

執行結果:

Problem: 1056

 

User: uestcshe

Memory: 192K

 

Time: 0MS

Language: C++

 

Result: Accepted

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章