杭電 1242 Rescue(廣搜)

http://acm.hdu.edu.cn/showproblem.php?pid=1242

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15597    Accepted Submission(s): 5663

Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 
Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 
Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
13
 
剛開始看到這個題的時候覺得用模板就行啦,不算難,可是敲出代碼提交一直錯,真心一下子想不通,想我這樣脾氣暴躁的人,簡直要被氣死了。委屈
AC代碼(一):用廣搜模板做的,僥倖AC。
#include<iostream>
#include<cstring>
#include<cstdlib>
#include<queue>
using namespace std;
#define max 201

char a[max][max];
int move[4][2]={-1,0,1,0,0,1,0,-1},v[max][max];//移動方向排列在這裏很重要。
int n,m,ans;
struct node
{
    int x,y,step;
};

void bfs(int i,int j)
{
    queue<node>q;
    node now,next;
    now.x=i;
    now.y=j;
    v[now.x][now.y]=1;
    now.step=0;
    q.push(now);    
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if(a[now.x][now.y]=='r')
        {
            ans=now.step;
            return ;
        }
        else
        {
            for(int t=0;t<4;t++)
            {
                next.x=now.x+move[t][0];
                next.y=now.y+move[t][1];
                if(!v[next.x][next.y]&&a[next.x][next.y]!='#'&&next.x>=0&&next.x<n&&next.y>=0&&next.y<m)
                {
                    v[next.x][next.y]=1;
                    if(a[next.x][next.y]=='.'||a[next.x][next.y]=='r')
                        next.step=now.step+1;
                    else
                        if(a[next.x][next.y]=='x')
                            next.step=now.step+2;
                        q.push(next);
                }
            }            
        }
        
    }
    return ;
}


int main()
{
    int i,j;
    while(cin>>n>>m)
    {
        ans=0;
        memset(v,0,sizeof(v));
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                cin>>a[i][j];
            }
        }
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(a[i][j]=='a')
                    bfs(i,j);
            }
        }
            if(ans)
                cout<<ans<<endl;
            else
                cout<<"Poor ANGEL has to stay in the prison all his life.\n";
    }
    return 0;
}

AC代碼(二):用優先隊列做的,比上一個靠譜些。
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;

#define M 205
char c[M][M];
int v[M][M];
int w[4][2]={-1,0,0,-1,0,1,1,0};
int ans,n,m;

struct node 
{
	int x,y,time;
	friend bool operator< (const node a,const node b)
	{
		return a.time>b.time;
	}
};

void bfs(int a,int b)
{
	node now,tmp;
	priority_queue<node>   q;
	now.time=0;
	now.x=a;
	now.y=b;
	memset(v,0,sizeof(v));
	v[a][b]=1;
	q.push(now);

	while(!q.empty())
	{
		now=q.top();
		q.pop();
		if(c[now.x][now.y]=='r')
		{
			ans=now.time;
			return ;
		}

		for(int i=0;i<4;i++)
		{
			tmp.x=now.x+w[i][0];
			tmp.y=now.y+w[i][1];
			if(tmp.x>=0&&tmp.x<n&&tmp.y>=0&&tmp.y<m
				&&!v[tmp.x][tmp.y]&&c[tmp.x][tmp.y]!='#')
			{
				v[tmp.x][tmp.y]=1;
				if(c[tmp.x][tmp.y]=='r'||c[tmp.x][tmp.y]=='.')
					tmp.time=now.time+1;
				if(c[tmp.x][tmp.y]=='x')
					tmp.time=now.time+2;
				q.push(tmp);
			}
		}
	}
	return;
}

int main()
{
	while(cin>>n>>m)
	{
		int i,j,x,y;
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				cin>>c[i][j];
				if(c[i][j]=='a')
					x=i,y=j;
			}

		ans=0;
		bfs(x,y);
		if(ans)
			cout<<ans<<endl;
		else
			cout<<"Poor ANGEL has to stay in the prison all his life.\n";
	}

	return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章