POJ 3041-Asteroids-二分圖最大匹配

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2…K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

  • Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

核心思想:

將兩個數軸看作兩個集合,平面內存在某一點(x,y)意味着二分圖中x和y有一條邊,求最大匹配即可。

代碼如下:

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
const int N=520;
int n,G[N][N],p[N];
bool vis[N];
bool dfs(int x)
{
	for(int y=1;y<=n;y++)
	{
		if(!G[x][y]||vis[y])continue;
		vis[y]=1;
		if(!p[y]||dfs(p[y]))
		{
			p[y]=x;
			return 1;
		}
	}
	return 0;
}
int main()
{
	int k,x,y;
	cin>>n>>k;
	for(int i=0;i<k;i++)
	{
		scanf("%d%d",&x,&y);
		G[x][y]=1;
	}
	int ans=0;
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=n;j++)
			vis[j]=0;
		ans+=dfs(i);
	}
	cout<<ans<<endl;
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章