字典樹,HDU 1251 hash前綴

統計難題

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 29855    Accepted Submission(s): 11649


Problem Description
Ignatius最近遇到一個難題,老師交給他很多單詞(只有小寫字母組成,不會有重複的單詞出現),現在老師要他統計出以某個字符串爲前綴的單詞數量(單詞本身也是自己的前綴).
 

Input
輸入數據的第一部分是一張單詞表,每行一個單詞,單詞的長度不超過10,它們代表的是老師交給Ignatius統計的單詞,一個空行代表單詞表的結束.第二部分是一連串的提問,每行一個提問,每個提問都是一個字符串.

注意:本題只有一組測試數據,處理到文件結束.
 

Output
對於每個提問,給出以該字符串爲前綴的單詞的數量.
 

Sample Input
banana band bee absolute acm ba b band abc
 

Sample Output
2 3 1 0
 
需要統計在給定的字符串裏,以標準串爲前綴的個數
map應該也行,字典樹映射基礎題,算是模板吧
代碼:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

struct node
{
    int num;
    struct node *next[30];
    node()
    {
        memset(next,NULL,sizeof(next));
        num=0;
    }
};

void insert(node *&root,char s[])
{
     int i,k;
    node *p;
    if(!root) root=new node();
    p=root;
    for(i=0; s[i]; i++)
    {
if(p->next[s[i]-'a']==NULL)
            p->next[s[i]-'a']=new node();
        p=p->next[s[i]-'a'];
        p->num++;
    }

}
int suan(node *&root,char s[])
{
  int   i,k;
    node *p;
    p=root;
    for( i=0;s[i];i++)
    {
        if(p->next[s[i]-'a']==NULL)
            break;
        p=p->next[s[i]-'a'];
    }
    if(s[i])
        return 0;
    else return p->num;
}
int main()
{
    char s[11];
    node *root = new node();
    while(gets(s),*s)
    {
        insert(root,s);
    }
    while(gets(s))
    {
        printf("%d\n",suan(root,s));
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章