HDU 1.2.5 GPA(ACM step)

Problem Description
Each course grade is one of the following five letters: A, B, C, D, and F. (Note that there is no grade E.) The grade A indicates superior achievement , whereas F stands for failure. In order to calculate the GPA, the letter grades A, B, C, D, and F are assigned the following grade points, respectively: 4, 3, 2, 1, and 0.
 
Input
The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.
 
Output
Each line of input will result in exactly one line of output. If all upper case letters on a particular line of input came from the set {A, B, C, D, F} then the output will consist of the GPA, displayed with a precision of two decimal places. Otherwise, the message "Unknown letter grade in input" will be printed.
 
Sample Input
A B C D F
B F F C C A
D C E F
 
Sample Output
2.00
1.83
Unknown letter grade in input
 
Author
2006Rocky Mountain Warmup
 
Source
HDU “Valentines Day” Open Programming Contest 2009-02-14
 
Recommend
lcy

/*
	其實做個題太水了,不過就是在輸入輸出上我一時沒轉過彎兒
	連續輸入一行字母,一旦回車就結束,打印出平均分 
	原來試了試不開數組直接用變量保存總分,沒成功, 原因我忘了,所以只好開了個數組存每次的成績
	如果誰可以不開數組,能直接回復我一下嗎 
*/

#include <stdio.h>
#include <string.h>
void GPA(char *grade, int cnt);
int main(void)
{
	char ch, grade[1000] = {0};
	int cnt = 0;
	int i;
	
	while(scanf("%c", &ch)!=EOF)
	{
		if(ch >= 'A' && ch <= 'z')
		{
			grade[cnt] = ch; // 記錄分數 
			cnt ++;
		}
		if(ch == '\n')
		{
			GPA(grade, cnt);
			memset(grade, 0, cnt*sizeof(char));
			cnt = 0;
		}
		
	}
	
	return 0;
}	

void GPA(char *grade, int cnt)
{
	int i, Unknown = 0;
	double sum = 0;
	for(i = 0; i < cnt; i++)
	{
		switch(grade[i])
		{
			case 'A': sum += 4; continue;
			case 'B': sum += 3; continue;
			case 'C': sum += 2; continue;
			case 'D': sum += 1; continue;
			case 'F': continue;
			default : Unknown = 1; break;
		}
	}
	if(Unknown == 0)
		printf("%.2lf\n", sum / cnt);
	else
		printf("Unknown letter grade in input\n");	
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章