Proud Merchants 01揹包

K - Proud Merchants

  

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more. 
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi. 
If he had M units of money, what’s the maximum value iSea could get? 
 

Input

There are several test cases in the input. 

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money. 
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description. 

The input terminates by end of file marker. 
 

Output

For each test case, output one integer, indicating maximum value iSea could get. 
 

Sample Input

2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3

Sample Output

5
11

 

01揹包, 只要排個序就好了。 要想買的多,那麼我們Q - P 的差值就要越大的先選

#include <queue>
#include <cstdio>
#include <set>
#include <string>
#include <stack>
#include <cmath>
#include <climits>
#include <map>
#include <cstdlib>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <stdio.h>
#include <ctype.h>
#include <bitset>
#include <sstream>
#define  LL long long
#define  ULL unsigned long long
#define mod 10007
#define INF 0x7ffffff
#define mem(a,b) memset(a,b,sizeof(a))
#define MODD(a,b) (((a%b)+b)%b)
using namespace std;
const int maxn = 2e5 + 5;
const int NUM = 1e6 + 5;
int n;
struct node
{
    int p,q,v;
}e[maxn];
bool cmp(node a,node b)
{
    return (a.q - a.p) < (b.q - b.p);
}
int main()
{
    int n,m;
    int dp[maxn];
    while(~scanf("%d%d",&n,&m)){
      mem(dp,0);
      for(int i = 0; i < n; i++){
        scanf("%d%d%d",&e[i].p,&e[i].q,&e[i].v);
      }
      sort(e,e + n,cmp);
      for(int i = 0; i < n; i++){
        for(int j = m; j >= 0; j--){
          if(j >= e[i].q) dp[j] = max(dp[j],dp[j - e[i].p] + e[i].v);
        }
      }
      printf("%d\n",dp[m]);
    }

    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章