hdu1863 暢通工程

Description

省政府“暢通工程”的目標是使全省任何兩個村莊間都可以實現公路交通(但不一定有直接的公路相連,只要能間接通過公路可達即可)。經過調查評估,得到的統計表中列出了有可能建設公路的若干條道路的成本。現請你編寫程序,計算出全省暢通需要的最低成本。

Input

測試輸入包含若干測試用例。每個測試用例的第1行給出評估的道路條數 N、村莊數目M ( < 100 );隨後的 N
行對應村莊間道路的成本,每行給出一對正整數,分別是兩個村莊的編號,以及此兩村莊間道路的成本(也是正整數)。爲簡單起見,村莊從1到M編號。當N爲0時,全部輸入結束,相應的結果不要輸出。

Output

對每個測試用例,在1行裏輸出全省暢通需要的最低成本。若統計數據不足以保證暢通,則輸出“?”。

Sample Input

3 3 1 2 1 1 3 2 2 3 4 1 3 2 3 2 0 100

Sample Output

3 ?

AC Code

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <limits.h>
#include <queue>
#include <time.h>
#define inf 0x3f3f3f3f
#define maxn 32005
#define MOD 50000
using namespace std;
const double pi=acos(-1.0),ee=2.7182818284590452354;

struct edge{
	int s,en,cost;
}e[50000];

int n,m,f[110];

bool cmp(edge a,edge b)
{
	return a.cost<b.cost;
}


int getf(int cur)
{
	if(f[cur]==cur) return cur;
	else
	{
		f[cur]=getf(f[cur]);
		return f[cur];
	}
	
}

int merge(int a,int b)
{
	int fa,fb;
	fa=getf(a);
	fb=getf(b);
	if(fa!=fb)
	{
		f[fb]=fa;
		return 0;
	}
	return 1;
}

int main(int argc, char** argv) {
	while(cin>>n>>m,n)
	{
		int i,summ=0;
		for(i=1;i<=m;i++)
			f[i]=i;
		for(i=1;i<=n;i++)
			cin>>e[i].s>>e[i].en>>e[i].cost;
		sort(e+1,e+n+1,cmp);
		for(i=1;i<=n;i++)
		{
			if(merge(e[i].s,e[i].en)==0)
			{
				summ+=e[i].cost;
			}
		}
		int num=0;
		for(i=1;i<=m;i++)
		{
			if(f[i]==i)
			{
				num++;
			}
		}
		if(num==1)
		cout<<summ<<endl;
		else 
		puts("?");
	}
	return 0;
}





發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章