POJ 2470 Relatives (歐拉函數)

Relatives
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15269   Accepted: 7731

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

Source


大意:求n以內與n互質的數的個數

思路:若p爲x的素因子,則歐拉函數值φ(x)=x(1-1/p1)(1-1/p2)(1-1/p3)(1-1/p4)…..(1-1/pn)

上代碼:

#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<stack>
#include<vector>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
#define llinf 0x3f3f3f3f3f3f3f3f
#define mod (int)1e9+7
#define max 1e5+10
//直接實現法
int eular(int n)
{
	int res=n;
	for(int i=2;i*i<=n;i++)
	{
		if(n%i==0)//尋找質因子,不是互質的數,且找到的第一個必定爲素數
		{
			res=res/i*(i-1);
			while(n%i==0)//把該素因子全部約掉,就是說i再也不是n的因子了
				n/=i;
		}
	}
	if(n>1)//若最後一個大於1,說明這個也是他的質因子
		return res=res/n*(n-1);
	return res;
}
int main()
{
	int n;
	while(scanf("%d",&n)&&n)
	{
		printf("%d\n",eular(n));
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章