HDU 3501 Calculation 2 (歐拉函數)

Calculation 2

                                                                    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                    Total Submission(s): 4636    Accepted Submission(s): 1926


Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 

Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 

Output
For each test case, you should print the sum module 1000000007 in a line.
 

Sample Input
3 4 0
 

Sample Output
0 2

題意:給你一個數n,求小於n且不和n互質的數的和

思路:對於gcd( n , i )=1,有gcd( n , n-i )=1,故 n 以內的與 n 互質的數的和爲 φ(n)*n/2,除了1,2,其餘的φ(n)均爲偶數

歐拉函數的其他性質:

Euler函數表達通式:euler(x) = x(1 - 1 / p1)(1 - 1 / p2)(1 - 1 / p3)(1 - 1 / p4)…(1 - 1 / pn), 其中p1, p2……pn爲x的所有質因數,x>=1。euler(1) = 1(看情況而定,一般爲1)。
歐拉定理:對於互質的正整數a和n,有a^φ(n) ≡ 1 mod n。
歐拉函數是積性函數——若m, n互質,φ(mn) = φ(m)φ(n)。
若n是質數p的k次冪,φ(n) = p^k - p ^ (k - 1) = (p - 1)p ^ (k - 1),因爲除了p的倍數外,其他數都跟n互質。
特殊性質:當n爲奇數時,φ(2n) = φ(n)

上代碼:

#include<iostream>
#include<cmath>
#include<cstring>
#include<string>
#include<queue>
#include<cstdio>
#include<stack>
#include<vector>
#include<algorithm>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
#define llinf 0x3f3f3f3f3f3f3f3f
#define mod (ll)1000000007
//if gcd(n,i)==1,then gcd(n,n-i)==1,so 1 to m = euler(n)*n/2
//so the answer=n*(n-1)/2-euler(n)*n/2 use long long
ll euler(ll n)
{
	ll res=n;
	for(ll i=2;i*i<=n;i++)
	{
		if(n%i==0)
		{
			res=res/i*(i-1);
			while(n%i==0)
				n/=i;
		}
	}
	if(n>1)
		return res=res/n*(n-1);
	return res;
}
int main()
{
	ll n;
	while(scanf("%lld",&n)&&n)
	{
		ll res=euler(n);
		printf("%lld\n",((n*(n-1)/2)-(res*n/2))%mod);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章