Triangle Partition

Triangle Partition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 2140    Accepted Submission(s): 925
Special Judge

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

Sample Input

1

1  2

2  3

3  5

Sample Output

1       2       3


 

題解:凸包問題

題目條件保證了三個點一定不在同一直線上,所以只需要排序

#include<bits/stdc++.h>

using namespace std;

const int N = 3e3 + 7;
const int mod = 1e9 + 7;

struct node{
	int x,y,i;
}a[N];

bool cmp(node x,node y){
	return x.x < y.x;
}

int main(){
	int t;
	while(~scanf("%d",&t)){
		while(t--){
			int n;
			scanf("%d",&n);
			for(int i=0;i<3*n;i++)
			{
				scanf("%d %d",&a[i].x,&a[i].y);	
				a[i].i = i + 1; 
			}			
			sort(a,a+3*n,cmp);
			for(int i=0;i<3*n;i++){
				if((i+1) % 3 != 0)
					printf("%d ",a[i].i);
				else
					printf("%d\n",a[i].i);
			}
		}

	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章