幀中繼上集成ISIS之在點對點上集成ISIS

 

實驗拓撲圖如上所示:

R1配置:

R1#sh run
Building configuration...

Current configuration : 1155 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
 ip router isis
!        
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
!
interface Serial0/0.1 point-to-point
 ip address 200.3.3.1 255.255.255.0
 ip router isis 
 frame-relay interface-dlci 103    //CLNS映射
!
interface Serial0/0.2 point-to-point
 ip address 200.4.4.1 255.255.255.0
 ip router isis
 frame-relay interface-dlci 104  
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router isis
 net 49.0001.1111.1111.1111.00
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R3配置:

R3#sh run
Building configuration...

Current configuration : 1028 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
 ip router isis
!        
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
!
interface Serial0/1.1 point-to-point
 ip address 200.3.3.3 255.255.255.0
 ip router isis
 frame-relay interface-dlci 301  
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router isis
 net 49.0001.3333.3333.3333.00
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

 

R4配置:

R4#sh run
Building configuration...

Current configuration : 1028 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
 ip router isis
!        
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
!
interface Serial0/2.1 point-to-point
 ip address 200.4.4.4 255.255.255.0
 ip router isis
 frame-relay interface-dlci 401  
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router isis
 net 49.0001.4444.4444.4444.00
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

驗證實驗:查看路由表

R1# sh ip  route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    200.4.4.0/24 is directly connected, Serial0/0.2
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     3.0.0.0/24 is subnetted, 1 subnets
i L1    3.3.3.0 [115/20] via 200.3.3.3, Serial0/0.1
     4.0.0.0/24 is subnetted, 1 subnets
i L1    4.4.4.0 [115/20] via 200.4.4.4, Serial0/0.2
C    200.3.3.0/24 is directly connected, Serial0/0.1

R3#  sh ip  route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

i L1 200.4.4.0/24 [115/20] via 200.3.3.1, Serial0/1.1
     1.0.0.0/24 is subnetted, 1 subnets
i L1    1.1.1.0 [115/20] via 200.3.3.1, Serial0/1.1
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, Loopback0
     4.0.0.0/24 is subnetted, 1 subnets
i L1    4.4.4.0 [115/30] via 200.3.3.1, Serial0/1.1
C    200.3.3.0/24 is directly connected, Serial0/1.1

R4#   sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    200.4.4.0/24 is directly connected, Serial0/2.1
     1.0.0.0/24 is subnetted, 1 subnets
i L1    1.1.1.0 [115/20] via 200.4.4.1, Serial0/2.1
     3.0.0.0/24 is subnetted, 1 subnets
i L1    3.3.3.0 [115/30] via 200.4.4.1, Serial0/2.1
     4.0.0.0/24 is subnetted, 1 subnets
C       4.4.4.0 is directly connected, Loopback0
i L1 200.3.3.0/24 [115/20] via 200.4.4.1, Serial0/2.1

 

全網路由都有,實驗完成:

總結1.在點到點子接口下,命令”frame-relay interface-dlci” 同時啓動 IP 映射和CNLS 映射,所以不需要額外的 CLSN映

2.點到點子接口的映射根本沒有區分 IP 或者CLNS,所以命令“frame-relay interface-dlci”同時啓動IP 映
射和CNLS 映射

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章