MPLS *** 的基本配置(2)

配置
本例中的5 臺路由器配置如下:
 
Pescara
Current configuration:
!
version 12.2
!
hostname Pescara
!
ip cef
!
!--- Customer_A 的配置.
ip vrf Customer_A
!---啓用Customer_A 的*** 路由和轉發表 (VRF).
rd 100:110
!--- Route distinguisher creates routing and forwarding
!--- tables for a VRF.
route-target export 100:1000
!--- Creates lists of import and export route-target extended
!--- communities for the specified VRF.
route-target import 100:1000
!
!--- Customer_B 配置.
ip vrf Customer_B
rd 100:120
route-target export 100:2000
route-target import 100:2000
!
interface Loopback0
ip address 10.10.10.4 255.255.255.255
ip router isis
!--- Customer_A 的配置.
interface Loopback101
ip vrf forwarding Customer_A
!---將一個接口或者自接口和一個VRF 實例關聯起來.
ip address 200.0.4.1 255.255.255.0
!--- Loopback101 和 102 使用相同的IP 地址 200.0.4.1.這是准許的,因爲它們屬於2 個不用
客戶的VRF
no ip directed-broadcast
!
!--- Customer_B 的配置.
interface Loopback102
ip vrf forwarding Customer_B
ip address 200.0.4.1 255.255.255.0
!--- Loopback101 和 102 使用相同的IP 地址 200.0.4.1.這是准許的,因爲它們屬於2 個不用
客戶的VRF
no ip directed-broadcast
!
interface Serial2/0
no ip address
no ip directed-broadcast
encapsulation frame-relay
no fair-queue
!
interface Serial2/0.1 point-to-point
description link to Pauillac
bandwidth 512
ip address 10.1.1.14 255.255.255.252
no ip directed-broadcast
ip router isis
tag-switching ip
frame-relay interface-dlci 401
!
router isis
net 49.0001.0000.0000.0004.00
is-type level-1
!
router bgp 100
bgp log-neighbor-changes
!--- 啓用BGP 鄰居關係中斷的記錄.
neighbor 10.10.10.6 remote-as 100
neighbor 10.10.10.6 update-source Loopback0
!--- 配置BGP 鄰居.
!
!--- Customer A and B commands.
address-family ***v4
!--- 進入address-family ***v4 配置模式,配置和PE/P 路由器間的MP-BGP 路由會話。
neighbor 10.10.10.6 activate
neighbor 10.10.10.6 send-community both
!--- Sends the community attribute to a BGP neighbor.
exit-address-family
!
!--- Customer B commands.
address-family ipv4 vrf Customer_B
!--- 進入address-family ipv4 的配置模式下,配置和CE 間的路由會話,
redistribute connected
no auto-summary
no synchronization
exit-address-family
!
!--- Customer A commands.
address-family ipv4 vrf Customer_A
redistribute connected
no auto-summary
no synchronization
exit-address-family
!
ip classless
!
end
 Pesaro
 
Current configuration:
!
version 12.1
!
hostname Pesaro
!
!--- Customer A commands.
ip vrf Customer_A
rd 100:110
route-target export 100:1000
route-target import 100:1000
!
!--- Customer B commands.
ip vrf Customer_B
rd 100:120
route-target export 100:2000
route-target import 100:2000
!
ip cef
!
interface Loopback0
ip address 10.10.10.6 255.255.255.255
ip router isis
!--- Customer A commands.
interface Loopback101
ip vrf forwarding Customer_A
ip address 200.0.6.1 255.255.255.0
!
!--- Customer B commands.
interface Loopback102
ip vrf forwarding Customer_B
ip address 200.0.6.1 255.255.255.0
!
!--- Customer A commands.
interface Loopback111
ip vrf forwarding Customer_A
ip address 200.1.6.1 255.255.255.0
!
interface Serial0/0
no ip address
encapsulation frame-relay
no ip mroute-cache
random-detect
!
interface Serial0/0.1 point-to-point
description link to Pomerol
bandwidth 512
ip address 10.1.1.22 255.255.255.252
ip router isis
tag-switching ip
frame-relay interface-dlci 603
!
router isis
net 49.0001.0000.0000.0006.00
is-type level-1
!
router bgp 100
neighbor 10.10.10.4 remote-as 100
neighbor 10.10.10.4 update-source Loopback0
!
!--- Customer B commands.
address-family ipv4 vrf Customer_B
redistribute connected
no auto-summary
no synchronization
exit-address-family
!
!--- Customer A commands.
address-family ipv4 vrf Customer_A
redistribute connected
no auto-summary
no synchronization
exit-address-family
!
!--- Customer A and B commands.
address-family ***v4
neighbor 10.10.10.4 activate
neighbor 10.10.10.4 send-community both
exit-address-family
!
ip classless
!
end
 
 
Pomerol
 
 
Current configuration:
!
version 12.0
!
hostname Pomerol
!
ip cef
!
interface Loopback0
ip address 10.10.10.3 255.255.255.255
ip router isis
!
interface Serial0/1
no ip address
no ip directed-broadcast
encapsulation frame-relay
random-detect
!
interface Serial0/1.1 point-to-point
description link to Pauillac
ip address 10.1.1.6 255.255.255.252
no ip directed-broadcast
ip router isis
tag-switching mtu 1520
tag-switching ip
frame-relay interface-dlci 301
!
interface Serial0/1.2 point-to-point
description link to Pulligny
ip address 10.1.1.9 255.255.255.252
no ip directed-broadcast
ip router isis
tag-switching ip
frame-relay interface-dlci 303
!
interface Serial0/1.3 point-to-point
description link to Pesaro
ip address 10.1.1.21 255.255.255.252
no ip directed-broadcast
ip router isis
tag-switching ip
frame-relay interface-dlci 306
!
router isis
net 49.0001.0000.0000.0003.00
is-type level-1
!
ip classless
!
end
 
 
Pulligny
 
Current configuration:
!
version 12.1
!
hostname Pulligny
!
!
ip cef
!
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface Serial0/1
no ip address
encapsulation frame-relay
random-detect
!
interface Serial0/1.1 point-to-point
description link to Pauillac
ip address 10.1.1.2 255.255.255.252
ip router isis
tag-switching ip
frame-relay interface-dlci 201
!
interface Serial0/1.2 point-to-point
description link to Pomerol
ip address 10.1.1.10 255.255.255.252
ip router isis
tag-switching ip
frame-relay interface-dlci 203
!
router isis
passive-interface Loopback0
net 49.0001.0000.0000.0002.00
is-type level-1
!
ip classless
!
end
 
 Pauillac
Current configuration:
!
version 12.1
!
hostname pauillac
!
ip cef
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
ip router isis
!
interface Serial0/0
no ip address
encapsulation frame-relay
no ip mroute-cache
tag-switching ip
no fair-queue
!
interface Serial0/0.1 point-to-point
description link to Pomerol
bandwith 512
ip address 10.1.1.1 255.255.255.252
ip router isis
tag-switching ip
frame-relay interface-dlci 102
!
interface Serial0/0.2 point-to-point
description link to Pulligny ip address 10.1.1.5 255.255.255.252
ip router isis
tag-switching ip
frame-relay interface-dlci 103
!
interface Serial0/0.3 point-to-point
description link to Pescara
bandwidth 512
ip address 10.1.1.13 255.255.255.252
ip router isis
tag-switching ip
frame-relay interface-dlci 104
!
router isis
net 49.0001.0000.0000.0001.00
is-type level-1
!
ip classless
!
end
檢驗
本節講述瞭如何檢查你的配置是否工作正常.
· show ip vrf - Verifies that the correct VRF exists.
· show ip vrf interfaces - Verifies the activated interfaces.
· show ip route vrf Customer_A - Verifies the routing information on the PE routers.
· traceroute vrf Customer_A 200.0.6.1 - Verifies the routing information on the PE routers.
· show ip bgp ***v4 tag - Verifies the BGP.
· show ip cef vrf Customer_A 200.0.6.1 detail - Verifies the routing information on the PE  routers.

更多的排錯命令詳見: MPLS *** Solution Troubleshooting Guide.
下面的輸出是命令 show ip vrf 的結果
     Pescara#show ip vrf 
     Name                         Default RD                             Interfaces 
     Customer_A                100:110                              Loopback101 
     Customer_B                100:120                              Loopback102

下面的輸出是命令show ip vrf interfaces 的結果.
Pesaro#show ip vrf interfaces
   Interface                  IP-Address              VRF               Protocol
  Loopback101             200.0.6.1         Customer_A            up
  Loopback111             200.1.6.1         Customer_A            up
   Loopback102            200.0.6.1         Customer_B            up

下面的 show ip route vrf 命令的結果顯示在2 個***l 裏面都有相同的網段 200.0.6.0/24. 這是因爲兩個***客戶 Customer_A 和Customer_B 使用了重疊的IP 地址.

Pescara#show ip route vrf Customer_A
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR

Gateway of last resort is not set
C 200.0.4.0/24 is directly connected, Loopback101
B 200.0.6.0/24 [200/0] via 10.10.10.6, 05:10:11
B 200.1.6.0/24 [200/0] via 10.10.10.6, 04:48:11

Pescara#show ip route vrf Customer_B
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set
C 200.0.4.0/24 is directly connected, Loopback102
B 200.0.6.0/24 [200/0] via 10.10.10.6, 00:03:24

在Customer_A 的2 個站點間使用Traceroute,可能可以看到MPLS 網絡使用的label stack。
(如果配置mpls ip ttl .)
Pescara#traceroute vrf Customer_A 200.0.6.1
Type escape sequence to abort. Tracing the route to 200.0.6.1
1 10.1.1.13 [MPLS: Labels 20/26 Exp 0] 400 msec 276 msec 264 msec
2 10.1.1.6 [MPLS: Labels 18/26 Exp 0] 224 msec 460 msec 344 msec
3 200.0.6.1 108 msec * 100 msec
Note: Exp 0 是QoS 使用的一個字段
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章