rip綜合實驗

--R1-----R2-----R3--
--f0/0、s1/1-----s1/0、s1/1-----s1/0、f0/0--

要求:
○1R1與R2與R3之間起RIPv1,用debug查看RIPv1的信息。
○2 R1起5個Loopback接口,在R2和R3上只允許看到兩個Loopback試驗地址,在R2上起被動

接口與單播,並用debug查看他們的狀 態。
○3把R1與R2與R3升級爲RIPv2版 本,在R3上起5個具有子網功能的連續地 址,然後進行手

動彙總與自動彙總,查看他們的區別。
○4在R2 R3之間啓用密文認證

Router 1:
Ena
Config t
Hostname r1
Int f0/0
Ip add 192.168.1.1 255.255.255.0
No shu
Int s1/1
Ip add 192.168.2.1 255.255.255.0
No shu
Exit
Router rip
Network 192.168.1.0
Network 192.168.2.0
exit
 
Router 2:
Ena
Config t
Hostname r2
Int s1/0
Ip add 192.168.2.2 255.255.255.0
Clock rate 64000
No shu
Exit
Int s1/1
Ip add 192.168.3.1 255.255.255.0
Clock rate 64000
No shu
Exit
Router rip
Network 192.168.2.0
Network 192.168.3.0
Exit
 
Router 3:
Ena
Config t
Hostname r3
Int f0/0
Ip add 192.168.4.1 255.255.255.0
No shu
Int s1/0
Ip add 192.168.3.2 255.255.255.0
No shu
Exit
Router rip
Network 199.99.3.0
Network 199.99.4.0
Exit

 R1:

debug ip rip
*Mar  2 20:44:53.139: RIP: sending v1 update to 255.255.255.255 via

FastEthernet0/0 (192.168.1.1)
*Mar  2 20:44:53.139: RIP: build update entries
*Mar  2 20:44:53.143:   network 192.168.2.0 metric 1
*Mar  2 20:44:53.143:   network 192.168.3.0 metric 2
*Mar  2 20:44:53.143:   network 192.168.4.0 metric 3
*Mar  2 20:44:54.079: RIP: sending v1 update to 255.255.255.255 via Serial1/1

(192.168.2.1)
*Mar  2 20:44:54.079: RIP: build update entries
*Mar  2 20:44:54.083:   network 192.168.1.0 metric 1
*Mar  2 20:45:01.623: RIP: ignored v1 update from bad source 192.168.4.1 on

FastEthernet0/0
*Mar  2 20:45:01.755: RIP: received v1 update from 192.168.2.2 on Serial1/1
*Mar  2 20:45:01.759:      192.168.3.0 in 1 hops
*Mar  2 20:45:01.759:      192.168.4.0 in 2 hops


R1:

R1(config)#int lo 1
R1(config-if)#ip add 192.161.1.1 255.255.255.0
R1(config-if)#int lo 2
R1(config-if)#ip add 192.162.2.1 255.255.255.0
R1(config-if)#int lo 3
R1(config-if)#ip add 192.163.3.1 255.255.255.0
R1(config-if)#int lo 4
R1(config-if)#ip add 192.164.4.1 255.255.255.0
R1(config-if)#int lo 5
R1(config-if)#ip add 192.165.5.1 255.255.255.0
R1(config-if)#exit

R1(config-router)#net 192.161.1.0
R1(config-router)#net 192.162.1.0


R2(config-router)#passive-interface s1/0
R2(config-router)#neighbor 192.168.2.1
R2(config-router)#exit


R2:debug ip rip

RIP protocol debugging is on
R2#
*Mar  2 21:10:32.275: RIP: received v1 update from 192.168.3.2 on Serial1/1
*Mar  2 21:10:32.279:      192.168.4.0 in 1 hops
R2#
*Mar  2 21:10:35.311: RIP: sending v1 update to 192.168.2.1 via Serial1/0 (192.1
68.2.2)
*Mar  2 21:10:35.311: RIP: build update entries
*Mar  2 21:10:35.315:   network 192.168.3.0 metric 1
*Mar  2 21:10:35.315:   network 192.168.4.0 metric 2
R2#
*Mar  2 21:10:43.363: RIP: received v1 update from 192.168.2.1 on Serial1/0
*Mar  2 21:10:43.363:      192.161.1.0 in 1 hops
*Mar  2 21:10:43.363:      192.162.1.0 in 1 hops
*Mar  2 21:10:43.363:      192.168.1.0 in 1 hops
R2#
*Mar  2 21:10:52.003: RIP: sending v1 update to 255.255.255.255 via Serial1/1 (1
*Mar  2 21:10:52.003: RIP: build update entries
*Mar  2 21:10:52.007:   network 192.161.1.0 metric 2
*Mar  2 21:10:52.007:   network 192.162.1.0 metric 2
*Mar  2 21:10:52.007:   network 192.168.1.0 metric 2
*Mar  2 21:10:52.011:   network 192.168.2.0 metric 1



R1\R2\R3 分別啓用 RIPV2
在R3上起 5個連續的子網


R3(config-if)#int loop 1
R3(config-if)#ip add 172.1.0.1 255.255.0.0
R3(config-if)#int loop 2
R3(config-if)#ip add 172.2.0.1 255.255.0.0
R3(config-if)#int loop 3
R3(config-if)#ip add 172.3.0.1 255.255.0.0
R3(config-if)#int loop 4
R3(config-if)#ip add 172.4.0.1 255.255.0.0
R3(config-if)#int loop 5
R3(config-if)#ip add 172.5.0.1 255.255.0.0

R3:
R3(config-router)#network 172.168.0.0
R3(config-router)#network 172.168.1.0
R3(config-router)#network 172.168.2.0
R3(config-router)#network 172.168.3.0
R3(config-router)#network 172.168.4.0
R3(config-router)#no aut

R2:
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.168.0.0/24 is subnetted, 5 subnets
R       172.168.4.0 [120/1] via 192.168.3.2, 00:00:14, Serial1/1
R       172.168.5.0 [120/1] via 192.168.3.2, 00:00:14, Serial1/1
R       172.168.1.0 [120/1] via 192.168.3.2, 00:00:14, Serial1/1
R       172.168.2.0 [120/1] via 192.168.3.2, 00:00:14, Serial1/1
R       172.168.3.0 [120/1] via 192.168.3.2, 00:00:14, Serial1/1
R    192.168.4.0/24 [120/1] via 192.168.3.2, 00:00:20, Serial1/1
R    192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:04, Serial1/0
R    192.162.1.0/24 [120/1] via 192.168.2.1, 00:00:04, Serial1/0
R    192.161.1.0/24 [120/1] via 192.168.2.1, 00:00:04, Serial1/0
C    192.168.2.0/24 is directly connected, Serial1/0
C    192.168.3.0/24 is directly connected, Serial1/1



R3上 進行手動彙總


R3(config)#int s1/0
R3(config-if)#ip summary-address rip 172.168.0.0 255.255.248.0

R2:

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.168.0.0/21 is subnetted, 1 subnets
R       172.168.0.0 [120/1] via 192.168.3.2, 00:00:04, Serial1/1
R    192.168.4.0/24 [120/1] via 192.168.3.2, 00:00:04, Serial1/1
C    192.168.2.0/24 is directly connected, Serial1/0
C    192.168.3.0/24 is directly connected, Serial1/1


R3上去掉手動彙總,並開啓自動彙總:
R3(config)#int s1/0
R3(config-if)#no ip summary-address rip 172.168.0.0 255.255.248.0
R3(config-if)#exit
R3(config)#router rip
R3(config-router)#aut
R3(config-router)#auto-summary

R2上:

R2#clear ip route *
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R    172.168.0.0/16 [120/1] via 192.168.3.2, 00:00:01, Serial1/1
R    192.168.4.0/24 [120/1] via 192.168.3.2, 00:00:01, Serial1/1
C    192.168.2.0/24 is directly connected, Serial1/0
C    192.168.3.0/24 is directly connected, Serial1/1


R3上配置鑰匙鏈

R3(config)#key chain
R3(config)#key chain she
R3(config-keychain)#key 1
R3(config-keychain-key)#key-string asd
R3(config-keychain-key)#end

R2上配置鑰匙鏈
R2(config)#key chain she
R2(config-keychain)#key 1
R2(config-keychain-key)#key-string asd
R2(config-keychain-key)#end

R2\R3接口使用鑰匙鏈並使用密文加密配置
R3(config)#Inter s1/0
R3(config-if)#ip rip authentication key-chain she
R3(config-if)#ip rip authentication mode md5


R2(config)#int s1/1
R2(config-if)#ip rip authentication key-chain she
R2(config-if)#ip rip authentication mode md5


R2上:

R2#clear ip route *
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R    172.168.0.0/16 [120/1] via 192.168.3.2, 00:00:03, Serial1/1
R    192.168.4.0/24 [120/1] via 192.168.3.2, 00:00:03, Serial1/1
C    192.168.2.0/24 is directly connected, Serial1/0
C    192.168.3.0/24 is directly connected, Serial1/1
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章