poj2342-Anniversary party(動態規劃-樹形dp)

原題鏈接:http://poj.org/problem?id=2342

題目原文:

 

Anniversary party

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12098   Accepted: 6947

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

題目大意:

        一顆樹,n個節點,每個節點有一個權重。現在要選取一系列節點,如果選擇節點 i ,那麼 parent[i] 和 children[i] 都不能選,否則可選可不選。求一個選擇方案得到的最大權重。

解題思路:

        利用樹形dp,dp[i] [0] 表示未選擇節點 i 時,節點 i 的子樹的最大權重,dp[i][1] 表示選擇節點 i 時,節點 i 的子樹的最大權重。那麼 dp[i][0] += max{ dp[child[j]][0], dp[child[j]][1] }; dp[i][1] += dp[child[i]][0]; ans = max { dp[root][0], dp[root][1] }.

AC代碼:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int N = 6005;

int n;
int weight[N];
int parent[N];
int mask[N];
int dp[N][2];

void init()
{
	memset(mask, 0, sizeof(mask));
	memset(parent, 0, sizeof(parent));
	memset(dp, 0, sizeof(dp));
}

void dfs(int node)
{
	mask[node] = 1;
	dp[node][1] = weight[node];
	int i;
	for (i = 1; i <= n; i++)
	{
		if (parent[i] == node && !mask[i])
		{
			dfs(i);
			dp[node][1] += dp[i][0];
			dp[node][0] += max(dp[i][1], dp[i][0]);
		}
	}
}

int main()
{
	int i;
	while (scanf("%d", &n) != EOF)
	{
		init();
		for (i = 1; i <= n; i++)
		{
			scanf("%d", &weight[i]);
		}
		int a, b;
		while (scanf("%d%d", &a, &b), a || b)
		{
			parent[a] = b;
		}
		int root = 1;
		while (parent[root]) root = parent[root];
		dfs(root);
		printf("%d\n", max(dp[root][0], dp[root][1]));
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章