poj1463-Strategic game(樹形dp)

原題鏈接:http://poj.org/problem?id=1463

題目原文:

Strategic game

Time Limit: 2000MS   Memory Limit: 10000K
Total Submissions: 10117   Accepted: 4765

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree: 


the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description: 


  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads 
    or 
    node_identifier:(0) 


The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

題目大意:

         給一棵樹,給節點上放置士兵,使每條路徑都有士兵監視,問最少士兵放置數量。

解題思路:

        樹形dp,dp[i][0] / dp[i][1] 分別表示 i 不放置和放置士兵的子樹士兵最少數量。那麼 dp[v][0] = \sumdp[child[v][j]][1]; dp[v][1] = 1 + \summin { dp[child[v][j]][0], dp[child[v][j]][1] }.

AC代碼:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;

const int N = 1505;

vector<int> vec[N];
int n;
int mask[N];
int dp[N][2];

void init()
{
	int i;
	for (i = 0; i < n; i++)
	{
		vec[i].clear();
	}
	memset(mask, 0, sizeof(mask));
}

void dfs(int v)
{
	int i;
	dp[v][1] = 1;
	dp[v][0] = 0;
	for (i = 0; i < vec[v].size(); i++)
	{
		int c = vec[v][i];
		dfs(c);
		dp[v][0] += dp[c][1];
		dp[v][1] += min(dp[c][0], dp[c][1]);
	}
}

int main()
{
	while (scanf("%d", &n) != EOF)
	{
		init();
		int i, idx, num, t, j;
		for (i = 0; i < n; i++)
		{
			scanf(" %d:(%d)", &idx, &num);
			for (j = 0; j < num; j++)
			{
				scanf(" %d", &t);
				vec[idx].push_back(t);
				mask[t] = 1;
			}
		}
		int root;
		for (i = 0; i < n; i++)
		{
			if (!mask[i]) root = i;
		}
		dfs(root);
		printf("%d\n", min(dp[root][0], dp[root][1]));
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章