hdu2196-Computer(樹形dp, 樹上最遠距離)

原題鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=2196

題目原文:

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 36215    Accepted Submission(s): 6062


 

Problem Description

A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 



Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.

 

 

Input

Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.

 

 

Output

For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).

 

 

Sample Input


 

5
1 1
2 1
3 1
1 1

5
1 1
2 2
3 3
1 9

 

 

Sample Output


 

3
2
3
4
4
9
10
12
15
15

 

 題目大意:

        給一棵樹,計算每個節點的能到達的最遠距離。

解題思路:

        設 v 的子節點爲 c,v 的父節點爲 f。定義dp[i][0] 表示 i 節點子樹的最遠距離,dp[i][1] 表示 i 節點子樹的次遠距離,dp[i][2] 表示 i 節點的反向最遠距離(即:i 節點的父節點不經過 i 節點的最遠距離)maxc[i] 記錄i節點最遠距離經過的子節點。那麼得到狀態轉移方程如下:

【1】:dp[v][0] = max { dp[ci][0] + dist(v, ci) }, maxc[v] = ci;

【2】:dp[v][1] = max { dp[ci][0] + dist(v, ci) }, maxc[v] != ci;

【3】:dp[v][2] = max { dp[f][1] + dist(f, v), dp[f][2] + dist(f, v) }, maxc[f] == v;

             dp[v][2] = max { dp[f][0] + dist(f, v), dp[f][2] + dist(f, v) }, maxc[f] != v;

 

         一開始想的是把【1】、【2】、【3】式分別用一個dfs計算,後來發現  【1】、【2】可以合併。

AC代碼:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;

const int N = 10005;

int n;
vector<int> vec[N];
int dp[N][3];
int maxc[N];

void init()
{
	memset(dp, 0, sizeof(dp));
	memset(maxc, -1, sizeof(maxc));
	int i;
	for (i = 0; i <= n; i++)
	{
		vec[i].clear();
	}
}

void dfs(int v)
{
	int i;
	for (i = 0; i < vec[v].size(); i += 2)
	{
		int c = vec[v][i];
		int d = vec[v][i + 1];
		dfs(c);
		if (d + dp[c][0] >= dp[v][0])
		{
			dp[v][0] = d + dp[c][0];
			maxc[v] = c;
		}
	}
	// dfs2的內容合併到dfs1中
	for (i = 0; i < vec[v].size(); i += 2)
	{
		int c = vec[v][i];
		int d = vec[v][i + 1];
		if (c != maxc[v])
		{
			dp[v][1] = max(dp[v][1], d + dp[c][0]);
		}
	}
}

void dfs2(int v)
{
	int i;
	for (i = 0; i < vec[v].size(); i += 2)
	{
		int c = vec[v][i];
		int d = vec[v][i + 1];
		if (c != maxc[v])
		{
			dp[v][1] = max(dp[v][1], d + dp[c][0]);
		}
		dfs2(c);
	}
}

void dfs3(int v)
{
	int i;
	for (i = 0; i < vec[v].size(); i += 2)
	{
		int c = vec[v][i];
		int d = vec[v][i + 1];
		if (c == maxc[v])
		{
			dp[c][2] = max(max(dp[c][2], d + dp[v][1]), d + dp[v][2]);
		}
		else 
		{
			dp[c][2] = max(max(dp[c][2], d + dp[v][0]), d + dp[v][2]);
		}
		dfs3(c);
	}
}

int main()
{
	while (scanf("%d", &n) != EOF)
	{
		init();
		int i, a, b;
		for (i = 2; i <= n; i++)
		{
			scanf("%d%d", &a, &b);
			vec[a].push_back(i);
			vec[a].push_back(b);
		}
		dfs(1);
		// dfs2(1);
		dfs3(1);
		for (i = 1; i <= n; i++)
		{
			printf("%d\n", max(dp[i][0], dp[i][2]));
		}
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章