【PAT甲級】1101 Quick Sort

樣例2經過實驗,應該是一個不存在滿足條件的元素的測試用例,所以從這個角度可以思考可以查找問題出現在什麼地方.

題目的要求是求出所有滿足左邊都小於右邊都大於該數的元素。

本題用到了一個重要的性質,如果一個元素左邊的元素都小於它,右邊的元素都大於它,那麼快排後這個元素的位置不會發生變化,利用這種思想,先進行快排,判斷所有位置沒有發生變化的元素,再判斷原數組中是否所有左邊的元素都小於該滿足條件的元素(右邊顯然沒有必要進行判斷了)。注意如果用一般的暴力解決,大概率會出現超時的情況。也要注意結果的格式。

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

代碼爲:

#include<cstdio>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;

long long a[1000001];
long long b[1000001];
vector<long long> res;

int main()
{
    int N;
    bool flag1, flag2;
    scanf("%d", &N);
    for(int i = 0; i < N; i++)
    {
        scanf("%lld", &a[i]);
        b[i] = a[i];
    }
    sort(b, b + N);
    long long maxnum = -1;
    res.clear();
    for(int i = 0; i < N; i++)
    {
        if(b[i] == a[i] && maxnum < a[i])
        {
            res.push_back(a[i]);
        }
        if(maxnum < a[i])
            maxnum = a[i];
    }
    printf("%d\n", res.size());
    int cnt = res.size();
    if(cnt > 0)
    {
        for(int i = 0; i < cnt - 1; i++)
        {
            printf("%lld ", res[i]);
        }
        printf("%lld", res[cnt - 1]);
    }
    else
        printf("\n");//沒有這個會報格式錯誤
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章