POJ 2184——Cow Exhibition【01揹包、負值】

題目傳送門

變形的01揹包,其實問題的本質是保證智商和幽默感和不爲負數情況下的最大和。智商屬性體積,幽默感屬性爲價值,問題轉換爲求體積大等於0時的體積、價值總和。

Description

“Fat and docile, big and dumb, they look so stupid, they aren’t much
fun…”

  • Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si’s and, likewise, the total funness TF of the group is the sum of the Fi’s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input

  • Line 1: A single integer N, the number of cows

  • Lines 2…N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.
    Output

  • Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and
TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value of TS+TF to 10, but the new value of TF would be negative, so it
is not allowed.

題意:

先給出 N 頭奶牛(0<= N <= 100),每頭牛都有一個聰明值Si,幽默值Fi。現在想從這些牛裏面選出一些,讓(聰明值總和TS+幽默值總和FS)最大,但是同時TS和FS又不能夠爲負值。

分析:

用dp[i]表示i這個質量下的最大價值,因爲s[i]可能爲負數,所以先預處理把所有的s[i]都加上100000,然後dp[100000]=0,其餘dp[]=-inf.最後計算的時候從100000開始計算,如果dp[i]>=0,那麼表示此時的f[i]>=0,之前的ans和dp[i]+i-100000相比較。注意,如果循環到某個i,s[i]<0,那麼遍歷次序是從小到大的,其實這和一維揹包的原理有關,如果是二維的話,那麼都可以用從小到大的方式循環,因爲前面計算的值和後面的沒有影響,但用一維寫,前面可能會影響後面的,所以要避免這樣的影響,所以纔有順序。

AC代碼:

#include <iostream>
#include <vector>
#include <utility>
#include <cstring>
#include <algorithm>
#include <map>
#include <queue>
#include <stack>
#include <cstdio>
#include <fstream>
#include <set>
using namespace std;
typedef long long ll;
#define ios ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);

const int MAXN = 1e5;
#define INF 0x3f3f3f

int dp[2 * MAXN + 7];
int s[MAXN];
int f[MAXN];
int main() {
	int n;
	while (cin >> n) {
		for (int i = 1; i <= n; i++) {
			cin >> s[i] >> f[i];
		}
		fill(dp, dp + MAXN * 2 + 7, -INF);
		dp[MAXN] = 0;

		for (int i = 1; i <= n; i++) {
			if (s[i] < 0 && f[i] < 0)
				continue;

			if (s[i] > 0) {
				for (int j = MAXN * 2; j >= s[i]; j--) {
					if (dp[j - s[i]] > -INF)
						dp[j] = max(dp[j], dp[j - s[i]] + f[i]);
				}
			}
			else {
				for (int j = 0; j <= MAXN * 2 + s[i]; j++) {
					if (dp[j - s[i]] > -INF)
						dp[j] = max(dp[j], dp[j - s[i]] + f[i]);
				}
			}
		}
		int ans = -INF;
		for (int i = MAXN; i <= MAXN * 2; i++) {
			if (dp[i] > 0)
				ans = max(ans, dp[i] + i - MAXN);
		}
		if (ans == -INF)
			ans = 0;
		cout << ans << endl;
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章