HDU 2955——Robberies【01揹包變形】

題目傳送門
搶劫方案最優問題,需要一個簡單地轉換,我們求的是不被抓的概率而非被抓的概率,各個銀行的儲蓄總和爲揹包容量,體積爲單個銀行的儲蓄,價值爲不被抓概率。

Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

題意:

題目給出所能容忍的最大的被抓概率和n個銀行每個銀行的錢數及被抓概率。求解在不被抓的情況下所能偷的最大錢數。

分析:

首先是揹包容量的問題:因爲概率爲浮點數不好遍歷,所以選擇將銀行總錢數作爲揹包容量

其次是求不被抓情況下的最大錢數,即求最大的逃跑概率,所以是(1-p[i])。獨立事件用乘法。

然後從大到小遍歷揹包容量,概率超過(1-p)即輸出。

狀態方程:dp[j] = max(dp[j], dp[j - w[i]] * (1 - v[i])); //dp[i]爲搶i金幣後的總逃跑概率。

顯然dp[0]=1;

#include <iostream>
#include <vector>
#include <utility>
#include <cstring>
#include <algorithm>
#include <map>
#include <queue>
#include <stack>
#include <cstdio>
#include <fstream>
#include <set>
using namespace std;
typedef long long ll;
#define ios ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);

#define MAXN 10005

double dp[MAXN];
double v[MAXN];
int w[MAXN];
int main() {
	ios;
	int T;
	while (cin >> T) {
		while (T--) {
			memset(dp, 0, sizeof(dp));
			double m;
			int n;
			cin >> m >> n;
			int sum = 0;
			for (int i = 1; i <= n; i++) {
				cin >> w[i] >> v[i];
				sum += w[i];
			}
			dp[0] = 1;
			for (int i = 1; i <= n; i++)
				for (int j = sum; j >= w[i]; j--)
					dp[j] = max(dp[j], dp[j - w[i]] * (1 - v[i]));

			for (int i = sum; i >= 0; i--) {
				if (dp[i] > (1 - m)) {
					cout << i << endl;
					break;
				}
			}
		}
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章