簡單DP

Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 

Sample Input

2
2
20 25
40
1
8

Sample Output

08:00:40 am
08:00:08 am

之前就是以爲直接循環就可以了, 然而並不是這樣

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<ctype.h>
#include<math.h>
#include<iostream>
using namespace std;
#include<algorithm>
#define N 2100
int a[N], b[N], dp[N];
#define Max 0x3f3f3f3f
int main()
{
    int i, T;
    scanf("%d", &T);
    while(T--)
    {
        int n;
        scanf("%d", &n);
        for(i=1;i<=n;i++)
        {
            scanf("%d", &a[i]);
        }
        for(i=2;i<=n;i++)
        {
            scanf("%d", &b[i]);
        }
        dp[1]=a[1];
        for(i=2;i<=n;i++)
        {
            dp[i]=min(dp[i-1]+a[i], dp[i-2]+b[i]);
        }

        int h, m, s;
        s=dp[n]%60;
        m=(dp[n]/60)%60;
        h=dp[n]/3600;
        h=h+8;
        h=h%24;
        if(h>12)
            printf("%02d:%02d:%02d pm\n", h, m, s);
        else
            printf("%02d:%02d:%02d am\n", h, m, s);
    }
    return 0;
}


發佈了78 篇原創文章 · 獲贊 9 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章