HDU----1686

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: 

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais… 

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces. 

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap. 

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format: 

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W). 
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000. 

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T. 

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3

0

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<iostream>

int t[10005];
char a[1000005],b[10005];
int ans, len, len1;

void getnext()
{
    int i = 0,j = -1;
    t[0] = -1;
    while (i<len1)
    {
        if(j == -1 || b[i] == b[j])
        {
            i++;
            j++;
            if (b[i] != b[j])
                t[i] = j;
            else
                t[i] = t[j];
        }
        else
            j = t[j];
    }
}

void kmp()
{
    int i=0,j=0;
    getnext();
    while(i<len)
    {
        if(j==-1 || a[i]==b[j])
        {
            ++i;
            ++j;
        }
        else
            j=t[j];
        if(j == len1)
        {
            ans++;
            j = t[j];
        }
    }
}
int main()
{
    int n;
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        gets(b);
        gets(a);

        len = strlen(a);
        len1 = strlen(b);

        ans = 0;
        kmp();
        printf("%d\n",ans);
    }
    return 0;
}

發佈了78 篇原創文章 · 獲贊 9 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章