簡單

Description

SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2 <-> p, y^2 <-> q, z^2 <-> r, xy <-> u, yz <-> v, zx <-> w and the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which is a linear function with 9 variables. 

Now your task is to write a program to change f into g.

Input

The input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j.

Output

For each input function, print its correspondent linear function with 9 variables in conventional way on one line.

Sample Input

2
0 46 3 4 -5 -22 -8 -32 24 27
2 31 -5 0 0 12 0 0 -49 12

Sample Output

46q+3r+4u-5v-22w-8x-32y+24z+27
2p+31q-5r+12w-49z+12
真是個大坑,傻逼隊友說一個一個判斷,然後就,,,,就是用一個字符串搞定了
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<ctype.h>
#include<math.h>
#include<algorithm>


#define Max 0x3f3f3f3f
using namespace std;
char str[20]= {"pqruvwxyz"};


int main()
{
    int i, n, b[12];
    scanf("%d", &n);


    while(n--)
    {
        int f=0;


        for(i=0; i<10; i++)
            scanf("%d", &b[i]);


        for(i=0; i<10; i++)
        {
            if(b[i])
            {
                if(f && b[i]>0)
                    printf("+");


                if(b[i]==-1 && i!=9)
                    printf("-");


                if((b[i]!=1 && b[i]!=-1) || (i==9))
                    printf("%d", b[i]);


                if(i!=9)
                printf("%c", str[i]);
                f=1;
            }
        }
        printf("\n");
    }
    return 0;
}
發佈了78 篇原創文章 · 獲贊 9 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章