PAT-A1115. 二叉樹-構建BST,分層統計結點

題目鏈接:https://www.patest.cn/contests/pat-a-practise/1115
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
The right subtree of a node contains only nodes with keys greater than the node’s key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:
2 + 4 = 6

BST中插入一個結點(不考慮平衡),比較 結點值的大小,較小就插入左子樹,較大就插入右子樹。
層序遍歷時判斷哪些結點在同一層的一般思路是:標記該層最左邊的結點,當要彈出該標記結點時就意味着上一層已經遍歷結束,開始新的一層。

#include <iostream>
#include <queue>
#include <vector>
using namespace std;

int data[1010];

struct BTree {
    int data;
    BTree *lchild, *rchild;
};
BTree *T;


void InsertValue(BTree *father, BTree *node)
{

    if(node->data <= father->data){
        if(father->lchild == NULL)
            father->lchild = node;
        else
            InsertValue(father->lchild, node);
    }
    else{
        if(father->rchild == NULL)
            father->rchild = node;
        else
            InsertValue(father->rchild, node);
    }

}

void LevelOrder(BTree *root)
{
    queue<BTree*> qt;
    qt.push(root);
    BTree *left = NULL;
    bool findleft = false;
    vector<vector<int>> values;
    vector<int> vetemp;

    while (!qt.empty()) {
        BTree *temp = qt.front();
        qt.pop();
        if(temp == left){
            findleft = false;
            left = NULL;
            values.push_back(vetemp);
            vetemp.clear();
        }
        vetemp.push_back(temp->data);
        if(temp->lchild != NULL){
            qt.push(temp->lchild);
            if(!findleft){
                findleft = true;
                left = temp->lchild;
            }
        }
        if(temp->rchild != NULL){
            qt.push(temp->rchild);
            if(!findleft){
                findleft = true;
                left = temp->rchild;
            }
        }
    }
    values.push_back(vetemp);
    long a,b;
    a = values[values.size()-1].size();
    b = values[values.size()-2].size();
    cout << a << " + " << b << " = " << a+b <<endl;
}

int main()
{
    int num;
    cin >> num;

    T = new BTree();
    cin >> T->data;
    T->lchild = NULL;
    T->rchild = NULL;

    for(int i = 1; i < num; ++i){
        cin >> data[i];
        BTree *temp = new BTree();
        temp->data = data[i];
        temp->lchild = NULL;
        temp->rchild = NULL;
        InsertValue(T, temp);
    }

    LevelOrder(T);

    return 0;
}
發佈了23 篇原創文章 · 獲贊 5 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章