HDU - 5813(68/600)

Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.

For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.

Your task is constructing such a city. Now it’s your showtime!
Input
The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.
Output
For each test case, output “Case #X: Y” in a line (without quotes), where X is the case number starting from 1, and Y is “Yes” if you can construct successfully or “No” if it’s impossible to reach the requirements.

If Y is “Yes”, output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.
Sample Input
3
3
2 1 0
2
1 1
4
3 1 1 0
Sample Output
Case #1: Yes
2
1 2
2 3
Case #2: No
Case #3: Yes
4
1 2
1 3
2 4
3 4

沒說輸出最少的點
那就好構造了
從零倒着往前裝作拓撲排序的樣子

#include<bits/stdc++.h>
using namespace std;
struct p
{
    int z,y;
};
int tt[1500];
p dan[1000001];
int we=0;
int main()
{
    int T,n,u=0;
    cin>>T;
    while(T--)
    {
        memset(dan,0,sizeof(dan));
        we=0;
        cin>>n;
        for(int a=1;a<=n;a++)scanf("%d",&tt[a]);
        queue<int>q;
        for(int a=1;a<=n;a++){if(tt[a]==0)q.push(a);}
        if(q.size()==0)
        {
            printf("Case #%d: No\n",++u);
            continue;
        }
        while(!q.empty())
        {
            int zs=q.front();
            q.pop();
            for(int a=1;a<=n;a++)
            {
                if(!tt[a])continue;
                tt[a]--;
                if(!tt[a])q.push(a);
                dan[++we]={a,zs};
            }
        }
        int jc=0;
        for(int a=1;a<=n;a++)
        {
            if(tt[a])jc=1;
        }
        if(jc)
        {
            printf("Case #%d: No\n",++u);
            continue;
        }
        printf("Case #%d: Yes\n",++u);
        printf("%d\n",we);
        for(int a=1;a<=we;a++)
        {
            printf("%d %d\n",dan[a].z,dan[a].y);
        }
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章