HDU6092(83/600)

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has n positive A1−An and their sum is m. Then for each subset S of A, Yuta calculates the sum of S.

Now, Yuta has got 2n numbers between [0,m]. For each i∈[0,m], he counts the number of is he got as Bi.

Yuta shows Rikka the array Bi and he wants Rikka to restore A1−An.

It is too difficult for Rikka. Can you help her?

Input
The first line contains a number t(1≤t≤70), the number of the testcases.

For each testcase, the first line contains two numbers n,m(1≤n≤50,1≤m≤104).

The second line contains m+1 numbers B0−Bm(0≤Bi≤2n).

Output
For each testcase, print a single line with n numbers A1−An.

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.

Sample Input
2
2 3
1 1 1 1
3 3
1 3 3 1

Sample Output
1 2
1 1 1

這個題就是碰到的所有能碰的都算到答案裏去
字典序那句話可以說是廢話了
算進答案裏的去篩掉不能算進答案裏的

但是要從小的去篩掉大的

比賽的時候我妄圖用大的篩掉小的結果發現組合數算不出來就gg了

#include<bits/stdc++.h>
using namespace std;
long long bi[10010];
int dan[10010];
int main()
{
    int T,n,m;
    cin>>T;
    while(T--)
    {
        memset(dan,0,sizeof(dan));
        cin>>n>>m;
        for(int a=0;a<=m;a++)scanf("%lld",&bi[a]);
        for(int a=0;a<=m;a++)
        {
            if(dan[0]>=n)break;
            if(a<1)continue;
            if(!bi[a])continue;
            dan[++dan[0]]=a;
            for(int b=a;b<=m;b++)
            {
                bi[b]=bi[b]-bi[b-a];
            }
            a--;
        }
        int jc=0;
        for(int a=1;a<=dan[0];a++)
        {
            if(!jc)
            {
                printf("%d",dan[a]);
                jc=1;
                continue;
            }
            printf(" %d",dan[a]);
        }
        printf("\n");
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章