UVA-111 History Grading

Background

Many problems in Computer Science involve maximizing some measure according to constraints.

Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events?

Some possibilities for partial credit include:

  1. 1 point for each event whose rank matches its correct rank
  2. 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.

For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).

In this problem you are asked to write a program to score such questions using the second method.

The Problem

Given the correct chronological order of n events tex2html_wrap_inline34 as tex2html_wrap_inline36 where tex2html_wrap_inline38 denotes the ranking of event i in the correct chronological order and a sequence of student responses tex2html_wrap_inline42 where tex2html_wrap_inline44 denotes the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.

The Input

The first line of the input will consist of one integer n indicating the number of events with tex2html_wrap_inline50 . The second line will contain nintegers, indicating the correct chronological order of n events. The remaining lines will each consist of n integers with each line representing a student's chronological ordering of the n events. All lines will contain n numbers in the range tex2html_wrap_inline60 , with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces.

The Output

For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking.

Sample Input 1

4
4 2 3 1
1 3 2 4
3 2 1 4
2 3 4 1

Sample Output 1

1
2
3

Sample Input 2

10
3 1 2 4 9 5 10 6 8 7
1 2 3 4 5 6 7 8 9 10
4 7 2 3 10 6 9 1 5 8
3 1 2 4 9 5 10 6 8 7
2 10 1 3 8 4 9 5 7 6

Sample Output 2

6
5
10
9

題意:一次歷史考試,首先是n,有n個事件,第一行爲每個事件發生的正確時間,下面每行是學生提交的事件,對於學生提交的答案,給最多的分數。

        這個題因爲提交的每個時間發生的時間,但是最後要找的是學生答對的事件個數,已sample Input2的最後一組數據爲例! 3  1 2 4 9 5 10 6 8 7  這是正確答案,但是它代表的是第一個時間發生在3時刻,第二個事件發生在1時刻,、、、、必須全部轉換過來,在尋找學生提交的答案與正確答案的次序。

        要求一個最長公共子序列,如何求最長公共子序列,一個典型的dp問題。

        最長公共子序列的題目博客

代碼如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    int a[25], b[25], dp[25][25], n, t, i, j;
    while(scanf("%d",&n) != EOF)
    {
        for(i = 1; i <= n; i++)
        {
            scanf("%d",&t);
            a[t] = i;//第個數據在t時刻發生
        }
        while(scanf("%d",&t) != EOF)//判斷到結束即可
        {
            b[t] = 1;
            for(i = 2; i <= n; i++)
            {
                scanf("%d",&t);
                b[t] = i;
            }
            // 求兩個的最長公共子序列。
            memset(dp, 0, sizeof(dp));
            for(i = 1; i <= n; i++)
            {
                for(j = 1; j <= n; j++)
                {
                    if(a[i] == b[j])
                        dp[i][j] = dp[i - 1][j - 1] + 1;
                    else
                    {
                        dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]);
                    }
                }
            }
            printf("%d\n",dp[n][n]);
        }
    }
    return 0;
}





發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章