[貪心]UVA10382 Watering Grass

Problem E
Watering Grass
Input:
 standard input
Output: standard output
Time Limit: 3 seconds

n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the distance from the left end of the center line and its radius of operation.

What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?

Input

Input consists of a number of cases. The first line for each case contains integer numbers nl and w with n <= 10000. The next n lines contain two integers giving the position of a sprinkler and its radius of operation. (The picture above illustrates the first case from the sample input.)

 

Output

For each test case output the minimum number of sprinklers needed to water the entire strip of grass. If it is impossible to water the entire strip output -1.

Sample input

8 20 2

5 3

4 1

1 2

7 2

10 2

13 3

16 2

19 4

3 10 1

3 5

9 3

6 1

3 10 1

5 3

1 1

9 1

 

Sample Output

6

2

-1


(Regionals 2002 Warm-up Contest, Problem setter: Piotr Rudnicku)

 


題意:有一個草坪,在草坪中有一些噴水裝置,給出這個草坪的長和寬,和噴水裝置的位置和半徑,求最少放置多少個噴水裝置能使得草坪被全部覆蓋?

思路:題目一看,就知道是區間覆蓋問題,用貪心解決,因爲是圓形區域覆蓋不好計算,我們把圓形區域轉換到草坪上來,就變成了矩形區域,這樣就比較好計算了。

#include<iostream>
#include<algorithm>
#include<cmath>

using namespace std;

class Circle
{
public:
	double left,right;
}circle[10005];


int main()
{
	int num;
	double lenth,width;
	while(cin>>num>>lenth>>width)
		{
			int i,j,k=0;
			double pos,radius;
			for(i=0;i<num;i++)
				{
					cin>>pos>>radius;
					if(radius*2>=width)
						{
							double l,r;
							l=pos-sqrt(radius*radius-(width/2)*(width/2));
							r=pos+sqrt(radius*radius-(width/2)*(width/2));
							circle[k].left=l;
							circle[k++].right=r;
						}
				}
			double begin=0,end=lenth;
			double maxlen=0;
			int cnt=0;
			while(begin<end)
				{
					maxlen=0;
					for(i=0;i<k;i++)
						{
							if(circle[i].left<=begin&&circle[i].right>maxlen)
								{
									maxlen=circle[i].right;
								}
						}
					if(maxlen==begin)
						{
							cnt=-1;
							break;
						}
					cnt++;
					begin=maxlen;
				}
			cout<<cnt<<endl;
		}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章